1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After Rebuilding Apache Getting 500 Errors

Discussion in 'Server Configuration and Hosting' started by faeronsayn, Sep 7, 2012.

  1. faeronsayn

    faeronsayn Well-Known Member

    So after I rebuilt apache through Easy Apache, I am getting 500 errors on all my sites, even the ones that are not on xenForo. Which means that it probably has nothing to do with the requirements of xenForo.

    All my databases are on a remote mysql server, however that would display something like "A database error has occurred" on my xenForo page. So it seems that apache is the main problem at this time.

    I looked into the error logs and all I see is the following

    [Sat Sep 08 01:45:54 2012] [error] [client IP ADDRESS] Premature end of script headers: index.php

    Which doesn't give me enough information, or any at all.

    I also had this error

    PHP Deprecated: Comments starting with '#' are deprecated in /usr/local/lib/php.ini on line 1071 in Unknown on line 0, referer: My Website URL.

    I removed that line and that error stopped popping up.

    Besides these two errors I am not getting anything, so I am not exactly sure what's wrong.

    Any help would be appreciated.
  2. Walter

    Walter Well-Known Member

    Which settings did you change when you recompiled Apache?

    It could be all, from a permission problem to SuPHP....
    faeronsayn likes this.
  3. faeronsayn

    faeronsayn Well-Known Member

    I recompiled an older build, which seems to have done the trick.
  4. Digital Doctor

    Digital Doctor Well-Known Member

    Is there a relationship between SuPHP and Premature end of script headers: index.php ?
    What SuPHP build works with Xenforo ?
  5. Slavik

    Slavik XenForo Moderator Staff Member

    Easyapache seems to have some weird config settings when using the latest version which don't agree with XenForo.

    I recently had to roll back someones Apache version for the exact same issue.

    My suggestion? Learn to compile apache yourself :)

Share This Page