1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

after installing add-ons, where are they?

Discussion in 'Resource and Add-on Discussions' started by audiokid, Mar 1, 2014.

  1. audiokid

    audiokid Active Member

    I've uploaded two add-on, they installed correctly, I see them installed admin.php?add-ons/ but where are they? I mean, do they install a control somewhere ( other than the url to the resources website) so you can use the add-on? I'm expecting to see something .
     
  2. FredC

    FredC Well-Known Member

    depending on the Addon.. It should appear inside the Options menu
     
  3. audiokid

    audiokid Active Member

    I bet I am uploading these to the wrong directory. Do you add these into the upload directory of XenForo or does the upload directory simply mean, upload this to example: Library folder, js, folder etc?

    right now, I'm not seeing anything in my options?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Upload the contents of the upload directory.

    However, it's the .xml file which creates all the options, not the .php files.
    Are you sure you have installed them correctly and the add-ons have options?
     
  5. audiokid

    audiokid Active Member

    good question. I am uploading the content in the Upload to the Library and appropriate other directories of XenForo. Then importing the xml
    What is the "Upload" directory for in XenForo?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    There is no "upload" directory in XenForo.
    That is the name of the directory/folder in add-ons, indicating that the contents of said folder should be uploadded.

    This is the left pane of the FTP application when uploading add-on files:
    upload_2014-3-1_23-34-1.png

    Note how I am in the upload folder.
    So all I do is drag and drop the library and styles folders to the server.
     
  7. audiokid

    audiokid Active Member

    thanks, this is what i am doing then. weird not seeing any options to adjust.
     
  8. HWS

    HWS Well-Known Member

    If you see them installed in ACP, they are successfully installed.
    If they have options, you'll find them in ACP > Options (just beside the regular Xenforo options).

    Some add-ons do not have options, so they simply do what they are for without any settings.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Which add-ons do you believe there should be options for which you aren't seeing?
    Sometimes you may need to set the admin perms for the add-on to be able to manage it.
     
  10. audiokid

    audiokid Active Member

  11. Brogan

    Brogan XenForo Moderator Staff Member

    The first one has no options.
    The second one does - if you aren't seeing them, ask in the add-on thread for support.
     
  12. audiokid

    audiokid Active Member

    As I have just migrated my vbulletin I did in fact need to set my user group permissions. Once done, I see the add-ons!

    Thanks for your help :)
     

Share This Page