Resource icon

Ads Manager 2 by Siropu [Paid] 2.3.13

No permission to buy (€49.99)

Siropu

Well-known member
I haven't seen that issue reported before, but I think I know what could be the problem. I have made a change. Please re-download the latest version and rebuild add-on data.
 

Goose

New member
I haven't seen that issue reported before, but I think I know what could be the problem. I have made a change. Please re-download the latest version and rebuild add-on data.
ok ok ok... i found the problem.

I currently use a translation made by myself on XF, setting the Italian language on the forum, totally changing the page to create a banner.

English standard language:
205406

Italian language:
205407
 

Sal Collaziano

Active member
Once you upgrade to XF2, upload Ads Manager 2 and run the upgrade in ACP. It should work fine. Permissions and admin options must be set again in Ads Manager 2.
When you say "permissions", are you referring to setting the ability to see the ads in individual user groups? The settings in "user criteria" stay intact after the upgrade?
 

interforo

Active member
I have the issue that my ads keep loading and with the result that users click on unwanted parts of the screen because page is not fully load

Will this script fix this issue?
 

bzcomputers

Well-known member
This add-on has a feature called "Lazy loading" which loads the ad after the page loads.
Depending on screen size I sometimes hide (css display:none) certain ads (large ads on small screens for the most part). This works great but the ad still gets loaded even though it is not viewable. This isn't a huge problem but does make statistics like impression counts and CTR inaccurate.

Will the new "lazy loading" feature catch that the ad is hidden and not load it? If not is this something that could be added.
 

Siropu

Well-known member
Depending on screen size I sometimes hide (css display:none) certain ads (large ads on small screens for the most part).
You can use Device criteria to hide the ad instead of CSS.
Will the new "lazy loading" feature catch that the ad is hidden and not load it?
How are you hiding it? Are you wrapping the code in a div with a class, adding a class to the ad code itself or are you using the ad/package class setting?
 

bzcomputers

Well-known member
You can use Device criteria to hide the ad instead of CSS.
Just installed your add-on and didn't have the device criteria option previously. So, I might try device criteria. Although I prefer to able to set specific screen sizes limitations for ads though.

How are you hiding it? Are you wrapping the code in a div with a class, adding a class to the ad code itself or are you using the ad/package class setting?
Div and class, then adding class to ad code currently.

For example for a 728x90 banner ad the class css would look like:

Code:
@media all and (max-width: 740px) {
  .ad-at-breadcrumb {
      display: none;
  }
}
@media all and (min-width: 741px) {
  .ad-at-breadcrumb {
      display: inline-block;
  }
}
With this I know specifically that the 728px wide ad will not display on any screen smaller than 741px wide.
 

Recep Baltaş

Well-known member
OK, this is one of the best Ad manager add-on but if literally screws up the entire forum! After upgrading to XF 2.1, we had a lot of problems. Slow downs, unable to edit templates and even unable to update a ******** phrase took ages. Why? Because of this add-on.

After removing this add-on, which literally took 30 minutes, yes 30 real world minutes, the server load went from 20 to 3.xx.

If anyone is having a slow forum after 2.1, this could be your problematic add-on.
 

Siropu

Well-known member
After upgrading to XF 2.1, we had a lot of problems. Slow downs, unable to edit templates and even unable to update a **** phrase took ages. Why? Because of this add-on.
I'm using this add-on myself on my community and never had such issues. I'm on shared hosting.
How many styles do you have?
 

Siropu

Well-known member
Ads Manager has 1060 phrases and over 60 template modifications for positions and it seems that the more styles you have, the longer it takes to apply them when installing/upgrading/uninstalling and this has nothing to do with the add-on itself, since XF is handling that part.

You said you had a higher server load with this add-on installed but I don't see how when it has only two simple queries on a very small table. How big is your board? You also said that the issues started after you upgraded to XF 2.1? Was it ok before that?
 
Top