1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Admin account locked

Discussion in 'Troubleshooting and Problems' started by Apokalupsis, Oct 21, 2010.

  1. Apokalupsis

    Apokalupsis Active Member

    I can't complete the upgrade. I have missed too many login attempts (don't know why...was almost certain I entered the correct pw).

    But now I can't login to do anything and the board is just in a "void"....shut down w/o being able to upgrade.

    As an admin, how do you recover your pw?
  2. Mike

    Mike XenForo Developer Staff Member

    It clears itself in 15 minutes, IIRC. You should still be able to login via the front end, even while the board is closed for the upgrade, but filling in the CAPTCHA. (I'd have to confirm that.) I believe a successful login will clear that.

    Alternatively, you can clear the xf_login_attempt table.
  3. Apokalupsis

    Apokalupsis Active Member

    I cannot log in to the front end even though FF correctly saved my login info. It won't log me in.

    So I use the /install/ url to do the install. It asks me for a login (w/ white background or the Upgrade System login)). FF correctly remembered this and I'm in. It then asks me a 2nd time (w/ a blue background aka Admin CP) and this is where the hiccup is.


    I finally got in, remembered an old pw.

    But what would have happened had I not remembered? Would I have to uninstall the board? Is there no way to recover admin pw's in such instances?
  4. Mike

    Mike XenForo Developer Staff Member

    I'd reupload all files to ensure that everything is overwritten problem. If you still have problems, send me a PM with FTP and admin login details and I'll look into it.

    Alternatively, assuming you still have the files from the previous version, you can rollback to that. As a further point, if you turn on debug mode in the config.php file (add $config['debug'] = true; at the end), you will still be able to access the board while the upgrade is pending. That should help let you try to deal with the logging in issues.
  5. Mark.B

    Mark.B Well-Known Member

    This is definitely an issue. When I get to that blue screen, it refuses my password, even though I 100% know it's correct. I can clear the login attempts table which unlocks the account, but I still cannot log in.

    Login attempts on the "closed" front end are simply ignored and you get the login link again.
  6. Mark.B

    Mark.B Well-Known Member

    Recovered my password with debug mode but had to get the board to send me a new one, which is odd. I know what my password was, and the initial login worked, but the second one did not.
  7. Mike

    Mike XenForo Developer Staff Member

    Mark, are you still in a state where this happens? I would like to debug it as I can't reproduce it. If so, can you PM me details I can try with?
  8. Mark.B

    Mark.B Well-Known Member

    To be honest, I'm not really sure. I'm mid way through an import attempt (about 24% through the threads and posts stage, with over a million posts) so I'm not sure if it's possible to get back to that point without starting again.

    I did wonder about this...when I first installed beta 1 I created a new admin account, with a basic password that differed from the one on my live site, then I tried an import from vB3.8. Although the import wasn't completed, the user table did import so my vB account became merged with the new one I created as they had the same name and email. The two passwords would have been different, and *neither* of them worked on that admin screen, but I do wonder if something got confused there somehow...though I can't think how.

Share This Page