1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 About Moderator Tools

Discussion in 'Troubleshooting and Problems' started by Yenile, Dec 26, 2014.

  1. Yenile

    Yenile New Member


    Moderator, Admin and Super Admin cant see Thread Tools in threads for moderating, how I can fix it ?


  2. Amaury

    Amaury Well-Known Member

    Have you explicitly made them moderators and given them the necessary permissions?
  3. Andrej

    Andrej Well-Known Member

    Amaury likes this.
  4. Yenile

    Yenile New Member

    @Maru & @Andrej

    I made moderator/administrator and I selected all permission allow but still they cant see Thread Tools.

    I m owner and Super administrator, I cant see thread tools too
  5. Yenile

    Yenile New Member

  6. Chris D

    Chris D XenForo Developer Staff Member

    Being a Super Administrator is irrelevant.

    You need to make sure you are listed at Admin CP > Users > Moderators. You need to be set up as a Moderator.

    If you already are, to work out why the permissions aren't working, use the Analyze Permissions feature in Admin CP > Users > Analyze Permissions.
    Amaury and Yenile like this.
  7. Yenile

    Yenile New Member


    [​IMG] - [​IMG]

    Analyze Permission :


    I dont know, what s wrong ?
  8. Chris D

    Chris D XenForo Developer Staff Member

    If they are all "No/Never" then you will need to click the link to see more details.

    A screenshot of that will explain what exactly is wrong.
    Amaury likes this.
  9. Yenile

    Yenile New Member

    @Chris D Thanks :)

    Administrator and moderator : second user group is Registered user

    And I selected permission never for registered user

    All okey :)
  10. Tracy Perry

    Tracy Perry Well-Known Member

    I hope you aren't saying that their PRIMARY is administrator and moderator and they have a secondary of registered.
    If so, then that is NOT the suggested way of permissions and you will have problems that will be difficult to trouble shoot.
    ALL users (including you as super admin) should have REGISTERED as your primary and any additional groups as secondary.

    And if you follow that all users have registered as Primary, your setting a permission of NEVER for that group over-rides any other settings for any group.
    Amaury and Yenile like this.

Share This Page