1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 66% slower server response times after upgrading to 1.4.8

Discussion in 'Troubleshooting and Problems' started by DeltaHF, Jun 29, 2015.

  1. DeltaHF

    DeltaHF Well-Known Member

    After upgrading to 1.4.8 (from 1.4.7), I noticed a sharp increase in XenForo's application response times according to NewRelic. As you can see in these graphs, most pages were generated on the server in approximately 30ms; after the update, that has changed to 50ms - an increase of nearly 66%.

    Note that I performed the upgrade at approximately 12:00AM on June 27th. There were no other changes or upgrades performed at this time. This is a dedicated CentOS server running @eva2000's Centminmod. PHP-FPM 5.4.42, MariaDB 5.5.44.

    Any ideas on what might have caused this?

    Screen Shot 2015-06-29 at 3.59.37 PM.png

    Screen Shot 2015-06-29 at 4.39.12 PM.png

    Screen Shot 2015-06-29 at 4.39.32 PM.png
  2. Mike

    Mike XenForo Developer Staff Member

    There's only one thing that changed in 1.4.8 that is globally involved and it was a missing trophy check, though the check should only run on session creation (like promotions). Do you have a large number of trophies?
  3. DeltaHF

    DeltaHF Well-Known Member

    No, I'm actually not using the trophy system at all. :(

    I'm not running many add-ons but I'll go through them to see if one isn't happy with 1.4.8.
  4. DeltaHF

    DeltaHF Well-Known Member

    Yeah, no improvement after disabling non-essential add-ons (I left the official add-ons enabled - Media Gallery, Enhanced Search, and the Resource Manager).

    Has anyone else running NewRelic noticed a similar change, or am I alone in this?
  5. eva2000

    eva2000 Well-Known Member

    why not update to PHP 5.6.10 and benefit for performance gains that would offset the change you see from 1.4.7 to 1.4.8 ?
    DeltaHF likes this.
  6. DeltaHF

    DeltaHF Well-Known Member

    Great suggestion, @eva2000. :D

    Just updated to 5.6.10 from 5.4.42 and response times have dropped back down to pre-XenForo 1.4.8 levels. :)

    Screen Shot 2015-07-02 at 12.12.40 AM.png

    (Ignore the gap in the graph - it took me a while to get NewRelic reconfigured after the upgrade.)
  7. RoldanLT

    RoldanLT Well-Known Member

    And also, why not upgrade to MariaDB 10.0.20?
    DeltaHF likes this.
  8. RoldanLT

    RoldanLT Well-Known Member

    To save that /css.php resource hog request, Try BD Cache addon of @xfrocks.
    xfrocks and DeltaHF like this.

Share This Page