1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 404s with Friendly URL Enabled

Discussion in 'XenForo Questions and Support' started by taylor_smith, Feb 3, 2013.

  1. taylor_smith

    taylor_smith Well-Known Member

    Hello! I have the default .htaccess installed and mod_rewrite is enabled.

    The index page looks fine: http://noobist.com/community. Unfortunately, every other page gives a 404 error.

    What am I doing wrong?
     
  2. cclaerhout

    cclaerhout Well-Known Member

    Jake Bunce and taylor_smith like this.
  3. taylor_smith

    taylor_smith Well-Known Member

    I changed the rewrite base to /community, but still getting 404s.

    But ty!
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Possible causes of friendly URLs not working (usually manifests as "404 not found" error on forum pages):

    1) The .htaccess file is not in place in your forum directory.

    2) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    RewriteBase /xenforo

    3) Your server doesn't have mod_rewrite installed. Consult with your host about this.

    4) Your server doesn't have AllowOverride enabled:

    http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

    Consult with your host about this.
     
    taylor_smith likes this.
  5. taylor_smith

    taylor_smith Well-Known Member

    I've checked and doubled-checked points 1 and 2.

    On point 3, the urls to change--they just don't lead anywhere. Could this be an indication that mod_rewrite isn't installed?
     
  6. Luis

    Luis Well-Known Member

    To check if mod_rewrite is activated go to routeyourforum/admin.php?tools/phpinfo.php it will be shown your PHP configuration, then find the loaded modules at Configuration apache2handler
     
    taylor_smith likes this.
  7. taylor_smith

    taylor_smith Well-Known Member

    This is from my host:

     
  8. cclaerhout

    cclaerhout Well-Known Member

    May be you should try to redirect your host to this page: http://xenforo.com/help/friendly-urls/
    and ask him if there's anything wrong in your config that will prevent friendly urls to work normally.
     
    Jake Bunce and taylor_smith like this.
  9. taylor_smith

    taylor_smith Well-Known Member

    My host was able to make some tweaks and the friendly URLs are now working.

    Thanks to all of you! :)
     
    cclaerhout, Chimpie and Jake Bunce like this.
  10. Chimpie

    Chimpie Well-Known Member

    HostGator rocks!
     
  11. taylor_smith

    taylor_smith Well-Known Member

    Yep. For the cost, you get some hella good customer service.
     

Share This Page