Fixed 1.4 redactor ctrl z quirky

dethfire

Well-known member
Mess around typing and the doing Ctrl + z. Sometimes it remove the last word. Sometimes the last letter and sometimes nothing.
 

Moshe1010

Well-known member
I've noticed this in 1.3 as well. Sometimes it would delete an entire phrase, sometimes just the styling that was done before that and sometimes a single letter (Using Chrome 36 and OS X).
 

Chris D

XenForo developer
Staff member
I have to say I have also noticed some unpredictable results with undo and redo.

It's sometimes a little over zealous as to what it considers to be your last action; to the point where it can delete entire sentences.

A behaviour similar to an application such as Microsoft Word or similar would be good.

I've been seeing this since the 1.2 branch of code, but I didn't think of it as a big problem.
 

Karelke

Active member
Ctrl + Z (undo) and Ctrl + Y (redo) are indeed not working as expected. I'm experiencing this odd behavior in both XenForo 1.3 and 1.4.
 

Rob

Well-known member
I can confirm this also in chrome on ubuntu, plus chrome on android.
 

Teapot

Well-known member
Can confirm on every browser and OS I've ever used XF with; this has happened since 1.2.
 

Mike

XenForo developer
Staff member
Please give some specific examples of what you're doing (buttons clicked, actions taken), what undo does and what you expect undo to do.
 

Karelke

Active member
Please give some specific examples of what you're doing (buttons clicked, actions taken), what undo does and what you expect undo to do.
In the quick reply:

1) Enter the text "Test Test"

1.png

2) Hit 2x enter, write another text "Test"

2.png

3) Select the last paragraph with the mouse

3.png

4) Hit the delete button to remove the text

4.png

5) Hit CTRL + Z to restore the deleted text => it doesn't work, and the cursor automatically moves 1 paragraph upwards.

5.png
 

Claudio

Well-known member
In the quick reply:

1) Enter the text "Test Test"

View attachment 79971

2) Hit 2x enter, write another text "Test"

View attachment 79972

3) Select the last paragraph with the mouse

View attachment 79973

4) Hit the delete button to remove the text

View attachment 79976

5) Hit CTRL + Z to restore the deleted text => it doesn't work, and the cursor automatically moves 1 paragraph upwards.

View attachment 79975
The same on Windows 8.1 with latest Chrome stable version
 

Chris D

XenForo developer
Staff member
Did you roll out some of the changes yesterday? I thought I had noticed an improvement, then.

I've just done a rudimentary test and it does seem to be quite a bit better :)

I can't say for sure, but I think I noticed a similar over zealous behaviour in the template editor in the Admin CP but I haven't used it for a while so I appreciate that's pretty vague...
 

Mike

XenForo developer
Staff member
Just rolled out today.

Undo in the template editor is browser controlled.
 
Top