1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed 1.1: Massive problems with editing posts in IE9

Discussion in 'Resolved Bug Reports' started by twollert, Dec 6, 2011.

  1. twollert

    twollert Active Member

    There are massive problems with the "Edit Post" overlay in Internet Explorer 9 (Win7 x64). Try this:

    1. Open the overlay by clicking "Edit"

    -> Instead of one blank line you always have two between paragraphs. Sometimes it's not possible to mark parts of the post with the mouse (especially if you have a longer posting with quotes ect.).

    2. Make a few changes and click "Save Changes"

    3. Open the same post again by clicking "Edit"

    -> Now you're completly unable to do any changes. You have to close the overlay and reload the full thread page again.

    (The problem with the blank lines you also have on the "More Options..." page.)

    It's really a pain to edit posts with IE9 right now. :(
    soloarquitectura likes this.
  2. mrGTB

    mrGTB Well-Known Member

    Internet Explorer should have been burnt at the stake last bonfire night and never created again by MS. It's such a terrible bloated browser, I never ever use it, apart from checking how my sites changes look viewed in it. I had a bad nightmare once I was using it, then woke up.
    Adam Howard likes this.
  3. ChemicalKicks

    ChemicalKicks Well-Known Member

    I can reproduce this on occasions in Chrome.

    This happens to me more often when I have a YouTube video embedded in a post, I'll try and get a solid way to reproduce it.
  4. ChemicalKicks

    ChemicalKicks Well-Known Member

    Okay here's how to reproduce the same bug in Chrome.

    1. Click Post New Thread
    2. Enter title and in your post box just paste in a YouTube link and nothing else
    3. Click Create Thread
    4. Click Edit (try to edit something)

    For reference this is the YouTube link I used.
  5. soloarquitectura

    soloarquitectura Well-Known Member

  6. Kier

    Kier XenForo Developer Staff Member

    I can't reproduce the problem using Chrome 16.0.912.59 on Mac
  7. twollert

    twollert Active Member

    I can't reproduce it in Chrome 15.0.874.12 on Win7 (x64) either. But are you able to reproduce it (#1) in Internet Explorer 9?
  8. ChemicalKicks

    ChemicalKicks Well-Known Member

    Windows 7 32 not sure of the Chrome version as I'm at work but thinking about it I do have 2 addons installed, both adblockers. I'll try again with those disabled.
  9. Mike

    Mike XenForo Developer Staff Member

    I can reproduce it (the original report) to some degree, but it tends to fix itself after a little bit -- at least in terms of the clickable editor.

    The line breaks are strange to say the least.
  10. Mike

    Mike XenForo Developer Staff Member

    Well, the line break issue can be fixed in library/XenForo/BbCode/Formatter/Wysiwyg.php, by changing:
    $output = preg_replace('#<p>[ \t\r\n]*</p>#', '<p><br /></p>', $output);
    $emptyParaText = (XenForo_Visitor::isBrowsingWith('ie') ? '&nbsp;' : '<br />');
    $output = preg_replace('#<p>[ \t\r\n]*</p>#', '<p>' . $emptyParaText . '</p>', $output);
    If the editor hangs for a bit (and then fixes itself), unfortunately I don't think there's much we can do about that -- it used to happen in Firefox, but a browser update solved it.
  11. twollert

    twollert Active Member

    Thanks, Mike!
  12. ChemicalKicks

    ChemicalKicks Well-Known Member

    I can still reproduce this with all addons disabled.

    But to clarify a bit more I can click the cursor into place and I can type a bit of text but I can only ever press the return key once in a row, any additional presses of return do nothing until you type more text.

    So this would work (following on from my original steps)

    4. Click edit
    5. Place cursor at end of text and type (actually place cursor in existing text or at very end of)
    6. Save

    Try hitting the return key though, nothing will happen, you can place your cursor mid text and return once before you must place the cursor again. If you do not place the cursor after each return then you're stuck again.

    EDIT: Windows 7 32 Chrome 15.0.874.121 m
  13. Digital Doctor

    Digital Doctor Well-Known Member

    I've seen this problem for a long time.
    JVCode likes this.
  14. JVCode

    JVCode Well-Known Member

    Me too, I have problems with this every day, and I'm using chrome.
  15. mrGTB

    mrGTB Well-Known Member

    Have you also noticed at times when you paste text into TinyMCE how a huge space is created below what you paste, then if you hit the backspace delete button it's removed. I get that a lot if I'm pasting something wrote in XenForo locally over onto my live site.
  16. Digital Doctor

    Digital Doctor Well-Known Member

    I wrote the world's simplest AutoHotKey script to strip out everything but text.
    I find it useful.
    It won't help your members ...
  17. twollert

    twollert Active Member

    That problem is still not fixed in 1.1.1.
  18. Mike

    Mike XenForo Developer Staff Member

    I stated that was unfixable in my reply - it's a browser issue. (That's the problem with reporting multiple issues in one bug. :))
  19. ChemicalKicks

    ChemicalKicks Well-Known Member

    Which browser don't have this bug?
  20. psTubble27

    psTubble27 Well-Known Member

    As posted in another thread, I'm experiencing the same overall problem:

    My browser is IE9. Is there no way to make an exception in the code, to handle IE browsers? They do constitute the vast majority of the browsers on the market today.

Share This Page