• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed 1.1: Massive problems with editing posts in IE9

twollert

Active member
#1
There are massive problems with the "Edit Post" overlay in Internet Explorer 9 (Win7 x64). Try this:

1. Open the overlay by clicking "Edit"

-> Instead of one blank line you always have two between paragraphs. Sometimes it's not possible to mark parts of the post with the mouse (especially if you have a longer posting with quotes ect.).

2. Make a few changes and click "Save Changes"

3. Open the same post again by clicking "Edit"

-> Now you're completly unable to do any changes. You have to close the overlay and reload the full thread page again.

(The problem with the blank lines you also have on the "More Options..." page.)

It's really a pain to edit posts with IE9 right now. :(
 

mrGTB

Well-known member
#2
Internet Explorer should have been burnt at the stake last bonfire night and never created again by MS. It's such a terrible bloated browser, I never ever use it, apart from checking how my sites changes look viewed in it. I had a bad nightmare once I was using it, then woke up.
 

ChemicalKicks

Well-known member
#3
There are massive problems with the "Edit Post" overlay in Internet Explorer 9 (Win7 x64). Try this:

1. Open the overlay by clicking "Edit"

-> Instead of one blank line you always have two between paragraphs. Sometimes it's not possible to mark parts of the post with the mouse (especially if you have a longer posting with quotes ect.).

2. Make a few changes and click "Save Changes"

3. Open the same post again by clicking "Edit"

-> Now you're completly unable to do any changes. You have to close the overlay and reload the full thread page again.

(The problem with the blank lines you also have on the "More Options..." page.)

It's really a pain to edit posts with IE9 right now. :(
I can reproduce this on occasions in Chrome.

This happens to me more often when I have a YouTube video embedded in a post, I'll try and get a solid way to reproduce it.
 

ChemicalKicks

Well-known member
#4
Okay here's how to reproduce the same bug in Chrome.

1. Click Post New Thread
2. Enter title and in your post box just paste in a YouTube link and nothing else
3. Click Create Thread
4. Click Edit (try to edit something)

For reference this is the YouTube link I used.
Code:
http://www.youtube.com/watch?v=G4xkr7YbAd4&feature=g-vrec
 

Kier

XenForo Developer
Staff member
#6
Okay here's how to reproduce the same bug in Chrome.

1. Click Post New Thread
2. Enter title and in your post box just paste in a YouTube link and nothing else
3. Click Create Thread
4. Click Edit (try to edit something)

For reference this is the YouTube link I used.
Code:
http://www.youtube.com/watch?v=G4xkr7YbAd4&feature=g-vrec
I can't reproduce the problem using Chrome 16.0.912.59 on Mac
 

twollert

Active member
#7
I can't reproduce it in Chrome 15.0.874.12 on Win7 (x64) either. But are you able to reproduce it (#1) in Internet Explorer 9?
 

Mike

XenForo developer
Staff member
#9
I can reproduce it (the original report) to some degree, but it tends to fix itself after a little bit -- at least in terms of the clickable editor.

The line breaks are strange to say the least.
 

Mike

XenForo developer
Staff member
#10
Well, the line break issue can be fixed in library/XenForo/BbCode/Formatter/Wysiwyg.php, by changing:
Code:
$output = preg_replace('#<p>[ \t\r\n]*</p>#', '<p><br /></p>', $output);
to:
Code:
$emptyParaText = (XenForo_Visitor::isBrowsingWith('ie') ? '&nbsp;' : '<br />');
$output = preg_replace('#<p>[ \t\r\n]*</p>#', '<p>' . $emptyParaText . '</p>', $output);
If the editor hangs for a bit (and then fixes itself), unfortunately I don't think there's much we can do about that -- it used to happen in Firefox, but a browser update solved it.
 

ChemicalKicks

Well-known member
#12
I can't reproduce the problem using Chrome 16.0.912.59 on Mac
I can reproduce it (the original report) to some degree, but it tends to fix itself after a little bit -- at least in terms of the clickable editor.

The line breaks are strange to say the least.
I can still reproduce this with all addons disabled.

But to clarify a bit more I can click the cursor into place and I can type a bit of text but I can only ever press the return key once in a row, any additional presses of return do nothing until you type more text.

So this would work (following on from my original steps)

4. Click edit
5. Place cursor at end of text and type (actually place cursor in existing text or at very end of)
6. Save

Try hitting the return key though, nothing will happen, you can place your cursor mid text and return once before you must place the cursor again. If you do not place the cursor after each return then you're stuck again.

EDIT: Windows 7 32 Chrome 15.0.874.121 m
 

mrGTB

Well-known member
#15
I can reproduce it (the original report) to some degree, but it tends to fix itself after a little bit -- at least in terms of the clickable editor.

The line breaks are strange to say the least.
Have you also noticed at times when you paste text into TinyMCE how a huge space is created below what you paste, then if you hit the backspace delete button it's removed. I get that a lot if I'm pasting something wrote in XenForo locally over onto my live site.
 

twollert

Active member
#17
3. Open the same post again by clicking "Edit"

-> Now you're completly unable to do any changes. You have to close the overlay and reload the full thread page again.
That problem is still not fixed in 1.1.1.
 

psTubble27

Well-known member
#20
As posted in another thread, I'm experiencing the same overall problem:

3. Open the same post again by clicking "Edit"

-> Now you're completly unable to do any changes. You have to close the overlay and reload the full thread page again.
My browser is IE9. Is there no way to make an exception in the code, to handle IE browsers? They do constitute the vast majority of the browsers on the market today.