Post Guard Pro

Post Guard Pro 1.0.3

No permission to buy ($15.00)
Compatible XF 1.x versions
1.4, 1.5
Additional requirements
PHP 5.4+
MySQL 5.7.8+ (to transfer post guards from Post Guard basic), MySQL 5.4+ (otherwise)
License
https://yugensoft.com/product-license/
Updates duration
12 months (renew for $10)
Visible branding
No
Description

Post Guard Pro allows you to block invalid or disallowed content submissions using "Post Guards". If a user attempts to submit a prohibited form of content, it will fail and they will receive an error message that you specify for that post guard.

Example uses include:
- Preventing clickbait titles
- Forcing line breaks and punctuation
- Preventing common posting mistakes

It is easy to use, and highly customizable.

Features
  • Wide selection of commonly used Post Guards.
    • Minimum length
    • Uncapitalized first letter
    • Only quote
    • Words
    • Strings
    • Characters
    • Line breaks
    • Punctuation
    • External URL
    • Regex
  • Option to write custom guards with regular expressions
  • Select where guards apply to
    • Posts
    • Thread titles
  • Set the phrase name and text to show as the error message (internationizable)
  • Select the forums guards operate in
  • Select user groups to exclude from guards
  • Includes support for certain 3rd-party add-ons as new "Apply To" types (where present)
    • Siropu Chat

Instructions
  • In admin, go to Applications -> Post Guard Pro -> Manage
  • Click Create Post Guard.
  • Fill in the details, then click Save.
  • Test the guard performs as you expect by clicking Test next to it.

Installation

Upgrading from Post Guard (basic)

Note the following:
  • Any phrases in your current language (e.g. English) that are prefixed with pg_ will be transferred across from Post Guard (basic).
  • All existing Post Guards will be transferred across as guards with the 'Regex' type.
    • Note: You will still have to set the forums they will apply to, as well as the user groups to exclude.
  • The existing Post Guard (basic) add-on will be disabled (and should remain so to prevent doubling / interference).

Upcoming updates
  • New "Apply To" types (core & 3rd-party add-ons)

Screenshots

pgp3.PNGpgp1.PNGpgp2.PNGpgp4.PNG
Author
Yugensoft
First release
Last update
Rating
5.00 star(s) 2 ratings

More resources from Yugensoft

Latest updates

  1. v1.0.3

    Wording change.
  2. v1.0.2

    Added support for older PHP and MySQL versions
  3. v1.0.1

    Phrase fix

Latest reviews

5 star features! 5 star support!
I wrote more than a dozen rules, it kept my forum away from the ad & spam and made all new posts clean.
Good AddOn and very utility in the Forums. It automates many things and avoids unnecessary work. I recommend it for any type of Forum since it works very well and is very customizable. The author responds well to problems, so you will always have communication with him. Recommended AddOn.
Top