Zend server installation

Brogan

XenForo moderator
Staff member
IIS is using port 80.

Go to control Panel ---> Programs ---> turn on and off windows features and untick Internet Information services
Ah! I remember now I had the same problem when I installed XAMPP.

Is there any problem with turning IIS off and why can't I just leave Zend on port 81?

This stuff really isn't my area so thanks for the help.
 

nestor718

Active member
Interesting, I wonder what's using port 80 then?

I think I clicked on Apache.
Go to:

My Computer -> Manage -> Services and applications -> Internet Information Services -> Connections -> Sites

Then in the details pane you'll see the sites running and their ports. Zend installs itself there and with a random port. But the default website would be what you're interested in. If you don't see Zend listed there, then most likely you're running the Apache server. If the Default Website is active and it is using port 80 then that's the one you need to disable. Just select it and hit the stop button.
 

Shamil

Well-known member
IIS is using port 80.

Go to control Panel ---> Programs ---> turn on and off windows features and untick Internet Information services
IIS isn't installed by default.

Brogan, to check what is using port 80, use this command in command prompt (Start -> cmd)
netstat -o -n -a | findstr 0.0:80

Let's say that gives this as the output:
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 8744

Now check in Task Manager, for processes with ID 8744, and there's your app.

It might be Skype using port 80.

You can just stop the IIS service completely, from starting

Start -> Run > services.msc -> World Wide Web -> right click -> Properties -> Startup Type: Disabled
 

Blandt

Well-known member
Ah! I remember now I had the same problem when I installed XAMPP.

Is there any problem with turning IIS off and why can't I just leave Zend on port 81?

This stuff really isn't my area so thanks for the help.
If it's a dev machine leave it at port 81 it's just fine. but if for some reason IIS is on you are waisting resources and burdening your computer with unnecessary stuff :)
 

Brogan

XenForo moderator
Staff member
I already did the netstat -o command and this is what I got:
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 2200

What's weird is there is no service running with that ID.
Go to:

My Computer -> Manage -> Services and applications -> Internet Information Services -> Connections -> Sites
There's no entry for IIS.

Edit: Found it, it's Skype.

Skype does not use port 80.
It does on mine :D
 

Shamil

Well-known member
It depends with what version of windows.

Skype does not use port 80.
It really does.

I already did the netstat -o command and this is what I got:
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 2200

What's weird is there is no service running with that ID.

There's no entry for IIS.

Edit: Found it, it's Skype.


It does on mine :D
Glad to see it's sorted :)
 

Brogan

XenForo moderator
Staff member
Thanks all.

Likes duly apportioned :D

Out of interest, if I install Zend before Skype next time, presumably that won't cause a problem with Skype?
 

Shamil

Well-known member
Thanks all.

Likes duly apportioned :D

Out of interest, if I install Zend before Skype next time, presumably that won't cause a problem with Skype?
You need to set Skype not to use port 80 and 443. Tool->Options->Connection->Advanced. Check a box about port 80 and 443.
 

Brogan

XenForo moderator
Staff member
You need to set Skype not to use port 80 and 443. Tool->Options->Connection->Advanced. Check a box about port 80 and 443.
Thanks.
That's already checked so next time I'll install Zend first so it can reserve port 80.
 

Brogan

XenForo moderator
Staff member
After all that I had to go back to XAMPP :rolleyes:

Zend just didn't want to work with my current site, I was getting errors related to function:date on the home page and the forum wouldn't load at all with an error code beginning with 3 (I can't recall the exact number).

Just installed XAMPP and it went without a hitch and works fine.
 

Blandt

Well-known member
After all that I had to go back to XAMPP :rolleyes:

Zend just didn't want to work with my current site, I was getting errors related to function:date on the home page and the forum wouldn't load at all with an error code beginning with 3 (I can't recall the exact number).

Just installed XAMPP and it went without a hitch and works fine.
Those errors are related to php 5.3.3 You have to edit the php.ini
 

Blandt

Well-known member
Stick with what worked for you :)
Ideally use IIS but if it's working now just go with that :D
 

nestor718

Active member
I guess we can close this thread???

Just installed xF beta 2 on IIS/Win2k08 server and the installer worked flawlessly! I'm in the control panel right now setting it up.

Thanks xF crew for killing that bug! :D
 
Top