1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zend, PHP 3X, etc.

Discussion in 'General XenForo Discussion and Feedback' started by CoreIssue, May 31, 2013.

  1. CoreIssue

    CoreIssue Member

    EDIT to correct: PHP 5.3, not 3X.

    I have a number of decisions to make in the remainder of this year, so some questions.

    Definitely not an expert, but I know XF uses Zend, PHP 3X does not support Zend, an old vB script I have will not work with PHP 3X, some other newer programs will not work on less the PHP 3X, etc.

    Obviously, I have to make some choices for the future.

    So, regarding XF, any opinions from the pros here where XF stands in all the changing realities? Where is PHP heading regarding Zend?

    Your opinions are appreciated and thanks in advance.
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Considering that PHP is currently at around 5.1.15, I think it's time to update some scripts or dump them. ;)
    I think you may have made a typo as most of the modern scripts will not work on 3.x releases.
     
    Adam Howard likes this.
  3. CoreIssue

    CoreIssue Member

    Ah, you are correct. 5.3, not 3X. Don't know where my mind was on that one.

    I know my server host is running 5.2 and I can switch to 5.3, which is minimum for at least one script I am looking at.

    5.3 does not support Zend. Nor will my old vB 3.8.2 work on 5.3.
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    If I am understanding you correctly, then I do think that Zend supports up to 5.4 http://www.zend.com/en/solutions/php-5-4/.
     
  5. CoreIssue

    CoreIssue Member

    For PHP 5.2 and lower it uses Zend Optimizer. For 5.3 Zend Guard and for 5.4 Zend Studio. Different software.
     
  6. xf_phantom

    xf_phantom Well-Known Member

    wtf

    Zend Optimizer != Zend Guard != Zend Studio != Zend Framework != Zend Framework Components (which are used in XF)


    you don't need anything from your list to run xenforo
     
    Adam Howard likes this.
  7. Tracy Perry

    Tracy Perry Well-Known Member

    That's what had me confused (which is easily done right now - been up again now for 21 hours). It runs just fine as is on the latest stable release of PHP for Debian.
     
  8. CoreIssue

    CoreIssue Member

    Well, as I said, I am not an expert. BUT, if you Google "zend not working on php 5.3" you will see people lost Zend applications when the servers went 5.3. One quote was:
    As well, in your link, it most assuredly states different Zend applications for 5.2, 5.3 and 5.4 if you click the "older versions" link.

    Obviously there isn't one blanket answer to cover it all. But it does appear on the server side there are 3 distinct Zend applications. On the software we run it depends on the Zend Framework coding, it appears.

    So, I don't know and that is why I asked. I do know I will loose my vB 3.8.2 script if I want to run the other script I was looking at. That is a given.

    Seems to be a lot of variables.
     
  9. Chris D

    Chris D XenForo Developer Staff Member

    XenForo uses parts of Zend Framework. Zend Framework is compatible with certainly PHP 5.2, 5.3, 5.4 and 5.5. Probably earlier versions too.

    Zend Framework is not something that needs to be installed - it's just a collection of PHP functions that can be used (or not, as the case is with most of XenForo) to enhance or otherwise replace writing your own functions.

    You will have no issues running XenForo on your server.

    Where you might be getting conflicting information, however, is that Zend (which is effectively a company/developer) has a number of products. Zend Optimizer, Zend Guard, Zend Server, Zend Studio etc.

    None of those products are required for XenForo to function, none of those products are included in Zend Framework. Not all of them will work with older versions of PHP but that doesn't matter because they aren't a prerequisite to use XenForo or Zend Framework.
     
  10. CoreIssue

    CoreIssue Member

    Thank you for that answer. Clear and understandable.
     
  11. Adam Howard

    Adam Howard Well-Known Member

    I would suggest php 5.4

    It's overall backward compatible with php 5.5, which is due to be released soon.
    Release Candidate 2 was released last week http://php.net/archive/2013.php#id2013-05-23-1

    Updating to php 5.4 will better ready you for the move to 5.5 should the need come up later.

    And as suggested, it maybe time to update some of those scripts of yours.
     
  12. CoreIssue

    CoreIssue Member

    My server host offers up to 5.3. Currently 5.2.

    As said, I know my vB script is going to be history, but right now I have it tied up in a very special usage, so it will be November or December before I can make the move up.

    That leaves just one other decision to make, which I will make at that time.
     

Share This Page