• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Mail Confirmation etc. not working - SMTP Auth / PHP Mail???

#1
  1. Hey!
I am now trying to setup emailing for my forum. Currently my users dont receive confirmation emails and such. First I had the normal option enabled which sends over PHP i guess, but it didnt work.
Then I setup a Postfix SMTP Server and it didnt work and didnt give me any log.

Any idea how to fix? Is there a tutorial how to properly setup a smtp postfix server?

Thanks.
 
#4
Update:

I re-installed postfix, connect to localhost on port 25 via telnet. And I sent a test e-mail like that:

MAIL FROM:<noreply@domain.com>
250 2.1.0 Ok
RCPT TO:<my.name@gmail.com>
250 2.1.5 Ok
DATA
354 End data with <CR><LF>.<CR><LF>
Subject: Test Message

This is a test.

.

That Works and I did receive the email (in spam). But as soon as Im trying to connect the smtp server to my xenforo and try sending mails, I will not get any mails (not even in spam). There are also NO errors. Not even in /var/log/mail.log.

Could someone please help me. I dont get it.
 

Tracy Perry

Well-known member
#5
Have you told Postfix to accept/relay mail from another domain other than what the server domain is? Hopefully you did NOT set the server up as domain.com and your site is domain.com. You really should set the server up as a subdomain off a main domain. I have servers based on my redneckhost.com domain. One was whiskey.redneckhost.com and was the primary server (for mail). That server had my other forum domains on it also.