XF 1.5 Problem to send mail confirmation (SMTP error with smtp.gmail.com)

#1
Hello, confirmation mails are not being sent, after logging in in the admin console, I saw the following message repeated many times (a time per user)

Zend_Mail_Protocol_Exception: Email to IVANNEYA@HOTMAIL.COM failed: 'smtp.gmail.com ' appears to be a DNS hostname but cannot match TLD against known list, 'smtp.gmail.com ' does not appear to be a valid URI hostname, 'smtp.gmail.com ' does not appear to be a valid local network name - library/Zend/Mail/Protocol/Abstract.php:145


Clarification: the domain provider is Namecheap, where I have in the settings GMAIL as mail server, the option to setup it automatically in Namecheap.

Thank you,kind regards.
 

Tracy Perry

Well-known member
#2
#3
Hello Tracy Perry.

First of all thank you for answering.

Yes, I have a gmail APP account. I'm trying these settings to send the emails from 2 different domains (one the same I use with xenforo,and another one).

I did everything exactly like the second link you gave me. But now,I tried, instead of using "Gmail" automatic setting, to set the MX of gmail manually, I dont think it will solve the issue but trying wont harm.

Any other suggestion since I did everything exactly like that?

CLARIFICATION: I didn't the step 11, because I didnt find it,I did domain verification of course,and I can login in to my gmail account of the domains, but I never saw the step 11, maybe it is not updated and it was an old gmail step, or maybe can I reach that second verification somewhere?
 
Top