1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF patch causes gallery errors with embedded media

Discussion in 'Media Gallery Support' started by Neal, Sep 23, 2016.

  1. Neal

    Neal Well-Known Member

    Just to add that adding the patched files to 1.5.1 and 1.5.8 causes the media gallery to not allow video embedding as it results in an unknown error message most of the time, on occasion it causes a thumbnail generation error.
  2. Chris D

    Chris D XenForo Developer Staff Member

    To clarify, what version of the Media Gallery are you running?

    Is there anything logged in the XF Server Error log related to this error?

    We've not had any other reports of this so this likely requires some further investigation.
  3. Neal

    Neal Well-Known Member

    Media Gallery 1.1.7 with Xenforo 1.5.8 and Media Gallery 1.1.1 with Xenforo 1.5.1

    No, there are no errors at all generated which is strange and it just pops up with Unkown Error in the usual Xenforo error message box.

    I can give you access to the sites if required.
  4. Chris D

    Chris D XenForo Developer Staff Member

    If you can create a ticket from your customer area we will be happy to take a look but otherwise I'll try to reproduce this locally.

    Is there anything specific that reproduces the behaviour consistently such as a particular video?

    Have you applied any patches to the Gallery also?
  5. Neal

    Neal Well-Known Member

    No patches, and i've just reverted back to the files available in my download area to make it work again but obviously i'm worried about security. My sites are adfree these days and rely on donations, and I just can't justify upgrade costs unless the sites have thousand of users or at least some income :)

    I tried different Facebook and YouTube videos over a few hours trying to figure out what it could be before making the post after I replaced the files back to their original ones and noticed things working again.

    I'll send a ticket shortly.
  6. Neal

    Neal Well-Known Member

    I can't access support tickets as my licenses have expired ;)

    XenForo - Error
    You must have at least one up-to-date license to access this page.
  7. Chris D

    Chris D XenForo Developer Staff Member

    I'll be able to attempt to reproduce this shortly.

    In the meantime if you get a chance, it might be worth reapplying the patch and testing it with all other add ons disabled (even non Gallery ones) and also with any browser extensions disabled (especially ad or script blockers).
    Neal likes this.
  8. Chris D

    Chris D XenForo Developer Staff Member

    I have just done a clean installation of XF 1.5.8 with XFMG 1.1.7 and XF 1.5.1 with XFMG 1.1.1 both with the 1.5.10 patch applied.

    I have tried with a couple of YouTube videos and neither give me the issue being reported:


    I suspect, therefore, there's more at play here than just the security patch.

    Therefore the advice in my previous post applies, and it'll just be a case of trying to ascertain which add-on or customisation or other external factor is causing this.
  9. Neal

    Neal Well-Known Member

    I've tried three browsers (Edge, Chrome and Firefox) with and without addons, and disabled all addons on the sites (except for the media gallery).

    The site running 1.5.1 appears to add the file but no thumbnail is displayed - clicking Save Media doesn't save anything and the media doesn't show.


    On the 1.5.8, it just pops up with "The following error occurred....".


    These issues only appear when I add the security patches. If I use files from my customer account, it all works fine again. Could it be a hosting issue perhaps?

    I really appreciate your help on this by the way @Chris D
  10. Chris D

    Chris D XenForo Developer Staff Member

    Can you create a new style in the Admin CP and create the style with No Parent.

    This is then essentially the default XF style with no customisations.

    If you activate that style and then try again is the behaviour any different?
  11. Neal

    Neal Well-Known Member

    Exactly the same @Chris D

    1.5.1 also gives this when I try to delete the file before saving:

    The following error occurred:
    The requested attachment could not be found.
  12. Chris D

    Chris D XenForo Developer Staff Member


    If you can start a conversation with me and include login details for a user account that experiences the problem, and access to the Admin CP and perhaps login details for FTP access too, that'd be great.

    I'll see if I can get to the root of the problem for you.
    Neal likes this.
  13. Neal

    Neal Well-Known Member

    You can't fault the support and service here with XenForo. PM on its way.
  14. Chris D

    Chris D XenForo Developer Staff Member

    Thanks for that.

    Pleased to report the issue has been identified and fixed, for you.

    I'm not totally sure how it happened, and even less sure how it happened on two different XF installs, but a single file (as far as I can tell) was a much older version than it should be (perhaps circa XFMG 1.0.x).

    As a precaution I re-uploaded all of the XFMG files for both sites and this seems to have solved the problem.
    Neal likes this.
  15. Neal

    Neal Well-Known Member

    Thank you very much for solving the issue, Chris. It was really puzzling me and i'm extremely grateful for your help.

Share This Page