1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Xenforo won't let me use www.domain.net/download

Discussion in 'Troubleshooting and Problems' started by UKCraft, Sep 3, 2012.

  1. UKCraft

    UKCraft Member

    Hello,
    I am trying to make a downloads folder but when i go to www.domain.net/download it takes me to xenforo saying error but i want xenforo just to leave that folder alone, how do I do it?
    Thanks In Advance
    -Niall
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    If the /download directory exists on the server then XenForo's .htaccess file should not intercept the request.

    You can try adding a .htaccess file to that directory with this code:

    Code:
    RewriteEngine Off
    
    And/or add the red code to XenForo's .htaccess file:

    Code:
    #	Mod_security can interfere with uploading of content such as attachments. If you
    #	cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #	SecFilterEngine Off
    #	SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    
    	#	If you are having problems with the rewrite rules, remove the "#" from the
    	#	line that begins "RewriteBase" below. You will also have to change the path
    	#	of the rewrite to reflect the path to your XenForo installation.
    	#RewriteBase /xenforo
    
    	#	This line may be needed to enable WebDAV editing with PHP as a CGI.
    	#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
    	RewriteCond %{REQUEST_FILENAME} -f [OR]
    	RewriteCond %{REQUEST_FILENAME} -l [OR]
    	RewriteCond %{REQUEST_FILENAME} -d
    	RewriteRule ^.*$ - [NC,L]
    	RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt|download/) - [NC,L]
    	RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
    That will cause XenForo to explicitly ignore that directory.

    edit - fixed error in first code block
     
  3. UKCraft

    UKCraft Member

    Thanks jake for your reply,
    I am still new to all of this so can you walk me through it?
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Got FTP? See the .htaccess file? You just need to edit that file.
     
  5. UKCraft

    UKCraft Member

    I have a file with this code:
    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
     
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
    <IfModule mod_rewrite.c>
        RewriteEngine On
     
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
     
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
     
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Does that look like it?
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yep. Now add the red code from my previous post.
     
  7. UKCraft

    UKCraft Member

  8. Dan

    Dan Well-Known Member

    I see 2 issues in the photo you provided. The folder is Downloads, not download

    Notice the capital D and s on the end. Try domain.com/Downloads
     
    Jake Bunce likes this.
  9. UKCraft

    UKCraft Member

    Ok,
    So here is what i have done:
    i have copied the htaccess file to /downloads and edited the RewriteEngine to Off.
    Is this what i ment to do?
    Thanks in Advance
    -Niall
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    No. The .htaccess in /download would have only that one line:

    Code:
    RewriteEngine Off
    
    Or the other option is to edit XenForo's own .htaccess file.
     
  11. UKCraft

    UKCraft Member

    Thats goblues that was the error
    Thanks both of you
    -Niall
     
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Good catch. The .htaccess stuff shouldn't be necessary once you visit the correct URL (/Downloads with a capital D).
     
    Dan likes this.

Share This Page