XenForo Redirects for vBulletin

XenForo Redirects for vBulletin 1.1.9

No permission to download


Active member
My bad, I said I hadn't tested it ;)
No problem @Chris D . We understand you don't have test environment to test this.

I again tested tags.php and it threw below error:

Fatal error: Call to undefined method XF\Mvc\Entity\Finder::findOne() in /home/kentest/public_html/forum/tags.php on line 28

I have zero knowledge in PHP, but with my general programming knowledge (JAVA), I tracked it down that fetchOne() should be used instead of findOne() function.

And then, TAG redirects worked properly in the website I tested.

If I am right, please correct the tags.php file for others.

Please let me know in case I am wrong.

And, I will do the remaining testing for Redirection Scripts and update here very soon.


Trouble getting any change from this - it seems to make no difference.

Migration was vBulletin 3.8->XF1.5->XF 2.0, performed by a pro
vBulletin was in /forum and still fully exists
XenForo is in /newforum
Server is LiteSpeed
All I want is for links that were posted inside the forum (prior to migration, so they include /forum) to point to the new location. My old forum was never indexed by Google so that's not important (and can't be used for testing), all I'm looking at is links within the forum.

I believe I followed all instructions, but when I look at an old post that was migrated to the new place, links still go to the old place.

Any ideas? No urgency.


I just installed it and tried it out. Got this error, but maybe there is something that I did not do. All I have done so far is install the add-on.

MySQL statement prepare error [1146]: Table 'oblio98_xenforo.import_table_name' doesn't exist


Kier, can you offer somme advice?
I exported my vBulletin 4 into Xenforo, and it saved the same IDs into the import log table. I have installed the latest redirect script.
But the redirection is not working.
When I imported vBulletin data, Xenforo was in a sub folder. I have since moved Xenforo to root, and bulletin to vb4 folder. Can you give me a bit of code so the redirect can work? Or will it never work now as vBulletin is not in Root? I couldn't set up Xenforo in root originally as bulletin files would have got messy.

Hope you can help.

The Dawg

New install here.

I converted from VB4 to Xenforo2. My VB4 lives at domain.com/board, my Xenforo is at domain.com.

If I leave the VB4 in tact the pages still load, so I renamed the folder, recreated /board, then put the .htaccess and index.php from XF301VB.

The index points to domain.com, but the script says "Loading… There are no threads in this forum."

What part am I missing?


**Never mind, I just moved the forum to /board to solve it.
Last edited:


Fantastic addon, made life so much easier when converting from VB3. The only issue we have is 301 errors as google trying to locate the old archive posts in VB.

Is there anyway to locate these in XF2 and redirect to them?


I'm getting the old 'The requested page could not be found.' error. It looks like all the pieces are there, so I'm not sure what I'm doing wrong.

Here's a sample URL:

It should forward to this:

The correct info is in our import database and the import database is linked to XenForo Redirects for vBulletin 1.1.2:
MariaDB [xfforums]> SELECT * FROM xf_vb_import WHERE content_type='thread' AND old_id='826578'

| import_log_id | content_type | old_id | new_id |
| 1294484 | thread | 826578 | 826578 |

And we've got the rewrite rules in Litespeed's Rewrite tab for the site:
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

rewriteCond %{HTTPS} !on
rewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [R,L]

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.

RewriteBase /

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
I know the Rewrite rules are firing because by HTTP->HTTPS rewrite works fine.

I turned on RewriteLog and we never seem to get to rewriting. Ideas?


Well-known member
@skotos your rewrite rule looks to be sending everything to XF's index.php instead of executing the redirect stubs this add-on adds.
Last edited:


It looks like the problem was an interaction with Litespeed. Things wouldn't redirect properly if I used Litespeed's native redirection (in its control panel) but would if I enabled an htaccess file.

John Pierce

New member
I have installed the plugin (with no errors) and have successfully selected the import log table.

My issue is this:

- My old VB4 install was in /forums/ whereas my XF is in root. (But the VB4 install is on a different server so there was no /forums/ on this server)

Therefore, I followed the directions here:

... and created a /forums/ directory under the XF root directory and copied the index.php and htaccess.txt (changed to .htaccess) from /src/addons/XF301VB/SourceLocation/ to the /forums directory.

I then updated index.php in the /forums directory to point the dir variable to my XF directory.

- Here is the problem ... I have a page with the following old VB4 URL:

When I access this URL, I get the page but it is all text with no styling or images (see attached screenshot).

I am sure I missed something simple but I can't figure it out. Any help would be deeply appreciated.



  • XF_Redirect.png
    18.3 KB · Views: 8


XenForo moderator
Staff member
I have responded to your ticket but this thread may be the best place for community based input from others.

John Pierce

New member
I solved the issue. In case it helps anyone else, I merely added:

redirect 301 /forums/showthread.php /showthread.php

... above the rewrite rules in the .htaccess file in the forums subdirectory. That way the URL gets 'forums' removed from it BEFORE the redirect addon does its magic.



Active member
My problem is http works fine, but https doesn’t. It just ends up at the homepage. The problem is I have is “Enable board URL canonicalization” is on to get everyone using https because otherwise people using old http shortcuts get logged out all the time. But every time I see a https link to my old vBulletin site it forwards to the homepage.

If you type http://mydomain/showthread.php/####### it goes to the correct thread on https (but you are logged out). If you type https://mydomain/qwerty it gives you an error 404 which is fine, if you type https://mydomain/showthread.php/####### it forwards to the homepage, not the thread.

Any idea what that might be?
Last edited:


Active member
Well... I sat down and went through everything and it appears I had uploaded showthread.php, showposts.php etc. I can't remember why I would do it... damn stroke has messed up my brain up! 🙄

Weird how it worked for http but not for https but anyway... it works a treat now! 😀

CZ Eddie

Active member
Hi folks, what am I doing wrong?

My forum was migrated from vBulletin 4.2.x to Xenforo 2.1.
I installed the latest redirect plugin.

Set vBulletin import log table: archived_import_log

Copied/renamed .htaccess and index.php into the old forum's directory on the new server.

Edited index.php as follows:


// Enter the full path to your XenForo directory here:
$dir = '/usr/local/lsws/sites/labusas/public_html';

require($dir . '/src/XF.php');




But still get this message when opening old links from Google.

Oops! We ran into some problems.
The requested page could not be found.

Here is an example of the URL's:




Company info
Staff member