1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Xenforo not sending confirmation emails (Windows Server 2012 R2)

Discussion in 'XenForo Questions and Support' started by Archeon Khan, Feb 8, 2016.

  1. Archeon Khan

    Archeon Khan New Member

    Question in title, error looks like:

    Zend_Mail_Transport_Exception: Email to xJustinFoley@gmail.com failed: Unable to send mail. mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() - library\Zend\Mail\Transport\Sendmail.php:137
    Generated By: xJus, Today at 10:26 PM
    Stack Trace
    #0 C:\Nginx\html\community\library\Zend\Mail\Transport\Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 C:\Nginx\html\community\library\Zend\Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #2 C:\Nginx\html\community\library\XenForo\Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
    #3 C:\Nginx\html\community\library\XenForo\Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
    #4 C:\Nginx\html\community\library\XenForo\Model\UserConfirmation.php(153): XenForo_Mail->send('xJustinFoley@gm...', 'xJus')
    #5 C:\Nginx\html\community\library\XenForo\ControllerPublic\AccountConfirmation.php(108): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
    #6 C:\Nginx\html\community\library\XenForo\FrontController.php(351): XenForo_ControllerPublic_AccountConfirmation->actionResend()
    #7 C:\Nginx\html\community\library\XenForo\FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #8 C:\Nginx\html\community\index.php(13): XenForo_FrontController->run()
    #9 {main}
    Request State
    array(3) {
    ["url"] => string(57) "https://mineark.net/community/account-confirmation/resend"
    ["_GET"] => array(1) {
    ["/community/account-confirmation/resend"] => string(0) ""
    ["_POST"] => array(5) {
    ["_xfToken"] => string(8) "********"
    ["_xfConfirm"] => string(1) "1"
    ["_xfRequestUri"] => string(27) "/community/account/two-step"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Check and verify the SMTP and smtp_port settings in the php.ini file.

    If you are unsure how to do that, your host should be able to help.

    Otherwise you can try using the default PHP method.
  3. Archeon Khan

    Archeon Khan New Member

    If possible, could you elaborate more? I'm running Xenforo off of a dedicated server from SoYouStart (OVH branch), with nginx as the current web server, on Windows Server 2012 R2. I'm sorry if I am uneducated or blind to see this haha :).
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Archeon Khan

    Archeon Khan New Member

  6. Archeon Khan

    Archeon Khan New Member

    Members of my community want to join ASAP and they cant fully register because of this :p
  7. Archeon Khan

    Archeon Khan New Member

  8. Mike

    Mike XenForo Developer Staff Member

    PHP on Windows uses an SMTP server as configured in your php.ini file (with limited configuration options). If you want to use that, you'll need to setup a local SMTP server that PHP can use. I don't have any experience with Windows SMTP servers, so I couldn't make a recommendation here.

    Otherwise, you can go into XenForo's mail settings and point it at an external SMTP server that you have setup/access to.

Share This Page