• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Xenforo Htaccess 403 Error

|Jordan|

Active member
#1
I setup a new xenforo forum and whenever i upload the .htaccess file, the entire site 403 errors. Web server is apache and xenforo is installed to the root of the subdomain.

Any idea why this is happening and how to fix it?

P.S. Its the default .htaccess included with xenforo.
 

|Jordan|

Active member
#3
I setup a new xenforo forum and whenever i upload the .htaccess file, the entire site 403 errors. Web server is apache and xenforo is installed to the root of the subdomain.

Any idea why this is happening and how to fix it?

P.S. Its the default .htaccess included with xenforo.

Mod_rewrite is enabled and htaccess overrides are working because the previous vb forum was able to use them fine.

Here's the vhost entry concerning htaccess:

<Directory />
Options None
AllowOverride All
Order Allow,Deny
Allow from all
</Directory>
This is the only mention of AllowOverride in the entire vhost configuration for this vhost.
 

|Jordan|

Active member
#5
Tried that. Still doesnt work. I deleted everything in the htaccess file and enabled each entry line by line (in each section). The thing that's breaking it is: RewriteEngine On (even with all the rewrite rules disabled)
 

Brogan

XenForo moderator
Staff member
#8
I have merged both identical threads.
Please don't post in multiple forums as it results in duplicate effort.
 

Jake Bunce

XenForo moderator
Staff member
#10
The thing that's breaking it is: RewriteEngine On (even with all the rewrite rules disabled)
But you say that line works in vB? That may indicate some difference in the configuration of the two sites.

I usually only paste this for 404s, but here is my copy/paste about friendly URLs:

Possible causes of friendly URLs not working (usually manifests as "404 not found" error on forum pages):

1) The .htaccess file is not in place in your forum directory.

2) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

RewriteBase /xenforo

3) Your server doesn't have mod_rewrite installed. Consult with your host about this.

4) Your server doesn't have AllowOverride enabled:

http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

Consult with your host about this.