XenForo 1.5 supports PHP 7.2?

sajal

Active member
it's mentioned that XenForo supports PHP 7.2 as it's mentioned in the requirements. So is it true for Xenforo 1.5 too, right?
 

Chris D

XenForo developer
Staff member
It depends which version of XF 1.5.

Only the newest versions will support PHP 7.2 and 7.3.

For 7.2 support you likely need a release after January 2018. For 7.3 support you need a release after January 2019.

Please bear in mind that XenForo 1.5 is no longer supported so it will no longer receive bug fixes and will likely not be compatible with PHP 7.4 when it is released.

We only support XenForo 2.1.
 

Chris D

XenForo developer
Staff member
In that case, I think you should be ok for PHP 7.2. But you will need to upgrade to a newer version of XF 1.5 or XF 2.1 if you want to use PHP 7.3.
 
Top