1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Xenforo 1.4.0 Beta Email Cant be sent

Discussion in 'Troubleshooting and Problems' started by xH3LLRAIZ3Rx, Aug 7, 2014.

  1. xH3LLRAIZ3Rx

    xH3LLRAIZ3Rx Member

    When I try to Register I get this error in the Server Logs

    Error Info
    Zend_Mail_Transport_Exception: Email to [blocked] failed: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137
    Generated By: aelbourne, 3 minutes ago
    Stack Trace
    #0 /var/www/html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 /var/www/html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #2 /var/www/html/library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
    #3 /var/www/html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
    #4 /var/www/html/library/XenForo/Model/UserConfirmation.php(170): XenForo_Mail->send('alexander.merce...', 'xH3LLRAIZ3Rx')
    #5 /var/www/html/library/XenForo/ControllerAdmin/User.php(912): XenForo_Model_UserConfirmation->processUserModeration(Array, 'approve', true, '')
    #6 /var/www/html/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_User->actionModeratedUpdate()
    #7 /var/www/html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #8 /var/www/html/admin.php(13): XenForo_FrontController->run()
    #9 {main}
    Request State
    array (size=3)
    'url' => string 'http://aelborne.com/admin.php?users/moderated/update' (length=52)
    '_GET' =>
    array (size=1)
    'users/moderated/update' => string '' (length=0)
    '_POST' =>
    array (size=2)
    'users' =>
    array (size=1)
    2 =>
    array (size=2)
    ...
    '_xfToken' => string '********' (length=8)
     
  2. Mike

    Mike XenForo Developer Staff Member

    This is very likely just an indication of an issue with the mail system on your server. You would need root (or your host's) help to resolve it most likely, or you should send mail via SMTP.
     
  3. xH3LLRAIZ3Rx

    xH3LLRAIZ3Rx Member

    I have root access, how do I fix the issue? is there some terminal command I need to use? Im running Ubuntu Server 14.04
     
  4. Mike

    Mike XenForo Developer Staff Member

    You need to setup a mail transfer agent such as Postfix and ensure that PHP is configured to use it correctly (sendmail_path).
     
  5. xH3LLRAIZ3Rx

    xH3LLRAIZ3Rx Member

    Sorry to act dumb or anything, how do I do that?
     
  6. xH3LLRAIZ3Rx

    xH3LLRAIZ3Rx Member

    oh ok i see that sendmail_path in the php.ini is crossed out ; so were do I put the path?
     
  7. xH3LLRAIZ3Rx

    xH3LLRAIZ3Rx Member

    nvm i think its working now, just had to install sendmail
     
  8. xH3LLRAIZ3Rx

    xH3LLRAIZ3Rx Member

    is this correct? sendmail_path = /usr/sbin/sendmail -t -i -f "Do Not Reply <aelborne@gmail.com>"
     
  9. Mike

    Mike XenForo Developer Staff Member

    Don't put the -f parameter and value there.
     
  10. xH3LLRAIZ3Rx

    xH3LLRAIZ3Rx Member

    Ok thanks
     

Share This Page