• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 XenForo 1.3.0 Beta 4 install problems

#1
So i am trying to upgrade to XenForo 1.3.0 Beta 4 but when i upload and go to the upload folder to install i get permissions issues

So i do a chmod on the upload folder but the internal_data folder is missing, I checked the zip file and i don't see it in there as well, not sure if this is an error with the package or not but wanted to post it for the devs


XenForo 1.3.0 Beta 4 - Errors
The following errors occurred while verifying that your server can run XenForo:

  • The directory /home/..../public_html/forums/upload/data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
  • The directory /home/..../public_html/forums/upload/internal_data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
Please correct these errors and try again.
 

Jeremy

Well-known member
#2
If you are installing, you should download the full package. If you are upgrading use the upgrade package. If the directory is missing (and you are upgrading), create it or restore from a back up. You'll need both directories to be writeable.
 
#3
Jerrmy, I am upgrading from B3 so i download the upgrade package but the folder wasn't in the zip file so i am not sure if its just a blank empty folder or has files in it..
 
#6
The internal server error comes after I follow the directions below, I think there might be something missing or wrong with the Beta 4 zip file.



XenForo 1.3.0 Beta 4 - Errors
The following errors occurred while verifying that your server can run XenForo:

  • The directory /home/..../public_html/forums/upload/data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
  • The directory /home/..../public_html/forums/upload/internal_data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
Please correct these errors and try again.
 

Liam W

Well-known member
#9
Are you uploading the upgrade package to the correct location?

It looks like your forums are stored in public_html/forums, and you should be uploading the contents of the upload folder to that directory, not uploading the actual upload folder there.

Liam