[Xen-Soluce] Display Visitor Attachments

[Xen-Soluce] Display Visitor Attachments 2.1.0 Fix 2

No permission to download

XenSoluce

Well-known member
XenSoluce submitted a new resource:

[Xen-Soluce] Display Visitor Attachments - Allow you to let the guest usergroup to view attachments

Description :
  • This add-on allow you to let the guest usergroup to view attachments.
Feature summary :
  • Options :
    • Enable for threads :
      • Enable the option for threads
      • Allowed extensions for visitor attachments
Branding :
  • This add-on does not include branding.
Installation :
  • Download and unzip it.
  • Copy the src/addons/XenSoluce/DisplayVisitorAttachements directory...

Read more about this resource...
 

sbj

Well-known member
Can you explain how this works?

I did this for the unregistered usergroup:

1582731076560.png

And then have it enabled for threads with the options:

1582731123304.png

But I see no difference. Unregistered people still can't view images.
 

sbj

Well-known member
Hello, if you want unregistered people to view attachement you need to set the permission to "Yes"! ;)

Regards, SyTry
But if I do that, then they can see every attachment. Will your addon block the attachment types I have not entered in your addon?
 

SyTry

Well-known member
But if I do that, then they can see every attachment. Will your addon block the attachment types I have not entered in your addon?
Yes, this option is for that. If you want unregistered people to view PNG only, JPEG, etc ;)
 
  • Like
Reactions: sbj

sbj

Well-known member
I want unregistered people to see png, jpeg, gif.

But I don't want them to see pdf.

So in permission I set "view attachments" to "yes".
And then in your addon I do "png, jpeg, gif".

Correct?
 

DavidXLD

Active member
Hy everyone,
@SyTry, super add-on, definitely a must have for me thank you!
But I have an issue on XenForo 2.2 regarding "Article" forums.
As you know article forums allow to display a cover image in the forum view for each article.
Unfortunately the cover images are displayed in a low resolution, not the correct one like in the posts.
Is it something you can correct for making it work in article forum view?
Many thanks in advance
David
 

SyTry

Well-known member
Hy everyone,
@SyTry, super add-on, definitely a must have for me thank you!
But I have an issue on XenForo 2.2 regarding "Article" forums.
As you know article forums allow to display a cover image in the forum view for each article.
Unfortunately the cover images are displayed in a low resolution, not the correct one like in the posts.
Is it something you can correct for making it work in article forum view?
Many thanks in advance
David
Hello, thanks. Tagging @CRUEL-MODZ for this! :)

Regards, SyTry
 

CRUEL-MODZ

Well-known member
Hy everyone,
@SyTry, super add-on, definitely a must have for me thank you!
But I have an issue on XenForo 2.2 regarding "Article" forums.
As you know article forums allow to display a cover image in the forum view for each article.
Unfortunately the cover images are displayed in a low resolution, not the correct one like in the posts.
Is it something you can correct for making it work in article forum view?
Many thanks in advance
David
Hello,

We don't have the addon article, so for the moment it could be complicated. Sorry !

Regards, CRUEL-MODZ
 

DavidXLD

Active member
Hi Cruel,

@CRUEL-MODZ :
I think I was not enough clear, sorry for that.
I do not use an addon article.

I am just talking about the Article forum type which is now native in Xenforo 2.2 :

If not enough clear I can PM you and explain in french... as I am french and you too 😂.
Please tell me and I will send you a link in order to help you to understand my issue.

Bonne journée
David
 
Top