Why might this template modification not work on all installations?

Chris D

XenForo developer
Staff member
OK. So this is, I thought, a pretty simple regular expression.

Find: /<xen:if is="{\$birthdays}">(.*?)<\/xen:if>/is
Replace: $0<xen:include template="member_list_block_newest" />

It's very simply supposed to be including a template at the end of the {$birthdays} block (on the member_notable template).

I am receiving various reports that suggest for some people it works, and other people it doesn't.

So either I've overlooked something, or there could be some sort of bug that might need reporting.
 

xIsabel38

Well-known member
I obviously don't know anything about specific code and all that. I have no idea what that expression means to be truthful. But have you tried to see what is in common between all the people that can see it and all the people that can't? Usergroup or permission settings perhaps?
 

Chris D

XenForo developer
Staff member
Thank you.

Think I have worked out it's an issue with PHP below version 5.4.
 

Chris D

XenForo developer
Staff member
Only if you want to use Widget Framework. Which not everyone does.

I believe it's a XenForo bug that Mike fixed, but I can't find the thread.
 

Shelley

Well-known member
Only if you want to use Widget Framework. Which not everyone does.

I believe it's a XenForo bug that Mike fixed, but I can't find the thread.
Agreed. There's two widgets in the xfrocks frame i like but got a coder to develop two of the widgets because of that reason. I didn't want to use or rather install a full blown FW.
 

Mike

XenForo developer
Staff member
Only if you want to use Widget Framework. Which not everyone does.

I believe it's a XenForo bug that Mike fixed, but I can't find the thread.
There isn't a thread for the particular bug you're running into, but I noticed it yesterday and fixed it. (It hides the error as an invalid regex.)
 

Brogan

XenForo moderator
Staff member
Add-ons should work with the lowest version of PHP which XenForo supports, which is 5.2.4.

Until that changes, if add-ons only work with PHP 5.4 and higher, they will not work on a lot of installations.
 

Robbo

Well-known member
Add-ons should work with the lowest version of PHP which XenForo supports, which is 5.2.4.

Until that changes, if add-ons only work with PHP 5.4 and higher, they will not work on a lot of installations.
I disagree. Add-ons should just be clear about which version they support. Mine are moving to 5.3+ as supporting 5.2 is time I don't have, it's like supporting IE 6 (which XenForo does, I don't).
 
Top