• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

RM 1.1 Why does a resource not always create a discussion thread?

gavpeds

Active member
#1
I am still playing with the resources manager and learning. I have set it to automatically create threads in certain areas for discussions.

The problem is i am noticing some resources created have not created a discussion thread. Why is this?
 

gavpeds

Active member
#3
This is the problem though. In each resource category i have specified a forum area for the discussion to be created in yet it still does not create a discussion every time o_O
 

gavpeds

Active member
#5
Ah ok so i think i may know the reason.

So i set up a category with two sub categories

Main cat (no posts allowed in this area or set up to create discussions)
1st sub cat (allowed to create a resource and set to post a discussion thread)
2nd sub cat (allowed to create a resource and set to post a discussion thread)

The two sub cats are the ones that seem not to be creating the discussion threads when a resource is posted.

UPDATE
ok so looking at it closer it seems the only category that is allowing discussion creation is the only one that i have set for posts to be moderated.

Could this be why all other categories are not posting discussions as all other categories i have are not set to moderate creation. Apparently that's not the reason! Just went and change a cat that is not posting discussions to moderate posts still no go.

http://windowcleaningforums.co.uk/resources/ the only cat that is posting discussions it the WCF Blog category
 
Last edited:

gavpeds

Active member
#6
Ok so it seems that the forum area has to be visible to uses for the discussion thread to be posted!

This is how i had it set.
Everything is working in posting discussions when a resource is created BUT my users were getting confused with the resource area on the forum list and the resource area as in the resource manger.

SO i thought ok we will just have to have the discussions on the actual resource and not show the forum area. I figured that would be fine but seems not.

I have another problem with this. I want my users to use the resource manager to post sales ads reviews and other things. The problem being if i have to have the area showing on the forum list members will just create new threads there and the resource manager wont be used. Am i making sense?o_O
 

Mike

XenForo developer
Staff member
#8
There aren't any options that relate to the setup of the forum that should prevent a thread from being created. It may be possible that there's another issue masking the problem.

If you can still reproduce it with your desired config, please submit a ticket with admin CP details and FTP details (note I may need to create some test resources to check it).

Also note that you can set permissions to remove the ability for people to post new threads in the target forum. The resource threads will still be created.
 

gavpeds

Active member
#9
Also note that you can set permissions to remove the ability for people to post new threads in the target forum. The resource threads will still be created.
Thats the problem right there, this is what i did and discussions stopped being created.
 

Mike

XenForo developer
Staff member
#10
Well we use that setup here and there are no permission checks in the code that creates the thread (though I suppose there could be an add-on that is involved).