1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Issue White page when delete language

Discussion in 'Resolved Bug Reports' started by Allan, Jan 15, 2011.

  1. Allan

    Allan Well-Known Member

    When i delete my french language, i am a white page error.

    Tested with this language (Spanish) and same problem.
     

    Attached Files:

  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try adding this line to the library/config.php file:

    Code:
    ini_set('display_errors', true);
    
    Does the white page show any specific errors now?
     
  3. Allan

    Allan Well-Known Member

    But i not understand, now it's work, with and wihtout add your code into config.php lol
     
  4. Vincent

    Vincent Well-Known Member

    Maybe it's a browser issue, I'll test it soon :)
     
  5. Allan

    Allan Well-Known Member

    With Chrome 9.0.597.47 beta
     
  6. Vincent

    Vincent Well-Known Member

    I just finished deleting your French Language Pack with Chrome 8 (latest release) and no white page showed up.
    I think that this is just a Chrome-Beta bug or something similiar to that. I don't see how this could be xenForo's problem :)
     
  7. Allan

    Allan Well-Known Member

    Yes, i think so, thank you Vincent ;)
     
  8. Mike

    Mike XenForo Developer Staff Member

    I actually think it's related to your server. I have optimized this process in a recent release though, so I'm not sure how much more can be done.
     
  9. Allan

    Allan Well-Known Member

    But I have an excellent server yet (dedicated).
     
  10. Vincent

    Vincent Well-Known Member

    He is talking about the configuration of your server :D
     
  11. Mike

    Mike XenForo Developer Staff Member

    I have removed some code that's not needed now, but it only applies when the language has children, which really won't be that common.

    There is another minor bit of code that might not be needed, but it really shouldn't cause this. Since you can't reproduce it any more, I'm going to tag this as a server issue for now. If you still have problems in the future, let me know - I'll probably need to login and debug to try to find where it's happening specifically.

    (On a side note, if you had debug mode on, disable it - it will save memory usage and speed things up.)
     
  12. Allan

    Allan Well-Known Member

    if the problem recurs, I will tell you.

    Yes, it's true that debug mode is also more resource.

    Thank Mike.
     

Share This Page