• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Which Xenforo Versions Will Support New Facebook APIs?

#1
We received a message from Facebook that our site "login has been making recent API calls to Graph API v2.0, which will reach the end of the 2-year deprecation window on Monday, August 8, 2016. Please migrate all calls to v2.1 or higher in order to avoid potential broken experiences."

I know some earlier versions of Xenforo don't support the newer Facebook API versions. I have two questions:

#1. What is the oldest version of Xenforo that will support Facebook API v2.1?
#2. If we upgrade to the latest Facebook API v2.6, what is the oldest version of Xenforo that will support that?

Thank you.
 
#6
Thank you! That's good to know. Last question. Which version supports 2.2 and 2.3? We have to decide how far to upgrade both the API and the Xenforo software at the moment.
 

Chris D

XenForo developer
Staff member
#7
We jumped from v2.0 in XF 1.4.8 to v2.4 in XF 1.5.0 and we're still using v2.4 in 1.5.9. We did not use v2.1, v2.2 or v2.3.
 

Warchamp7

Active member
#10
We jumped from v2.0 in XF 1.4.8 to v2.4 in XF 1.5.0 and we're still using v2.4 in 1.5.9. We did not use v2.1, v2.2 or v2.3.
Any chance of a minor point update for XenForo 1.4 to support 2.1+? Or is the only option for retaining that Facebook functionality to upgrade to 1.5? :[
 

Mike

XenForo developer
Staff member
#11
We don't have any plans to backport a change like that. At this point (and it has been this way for a while), 1.4 is only getting security fixes.
 

James

Well-known member
#14
Large number of add ons and my own template modifications. Upgrading major XF versions is a serious process for us
1.4 to 1.5 would not be considered a major XF version. I don't recall any fundamental changes that might stop addons working (check if the resources have been noted to work with that version) and your template mods can be merged using the template merge feature.
 

Warchamp7

Active member
#15
1.4 to 1.5 would not be considered a major XF version. I don't recall any fundamental changes that might stop addons working (check if the resources have been noted to work with that version) and your template mods can be merged using the template merge feature.
I am aware of how to go about it, don't worry. It's just very time consuming to go through every add on, check it's versioning if it's been updated, see if any add ons are replaced by built in functionality, do a mock upgrade, check template merges, etc. etc.