• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 when someone tried to register on my forum it shows error

Andrej

Well-known member
#2
You have "Use Full Friendly URLs" option enabled, however you missed out the notice below.
If you enable this option, the links generated by the system will not include "index.php?". However, to enable this, mod_rewrite must be available and an appropriate .htaccess file must be in place.
http://xenforo.com/help/friendly-urls/ (look at the information under 'Apache')
 

Attachments

Last edited:

Daniel-SP

Active member
#6
You may have to define the rewrite base in it (it is commented out) pointing to the base of your forum directory.
Tracy, could you explain what do you mean by that? I haven't got it.

Reading all the guides and some topics regarding this subject, the thing I understood was: I need to rename the txt to .htaccess and simply change the admin CP to to full friendly url option.
 

Tracy Perry

Well-known member
#7
Tracy, could you explain what do you mean by that? I haven't got it.

Reading all the guides and some topics regarding this subject, the thing I understood was: I need to rename the txt to .htaccess and simply change the admin CP to to full friendly url option.
It's documented in the htaccess.txt and why:
Code:
        #       If you are having problems with the rewrite rules, remove the "#" from the
        #       line that begins "RewriteBase" below. You will also have to change the path
        #       of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo