1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What controls the display of Any/Site/Album tabs at /media?

Discussion in 'Media Gallery Support' started by imthebest, Apr 15, 2015.

  1. imthebest

    imthebest Formerly Super120


    When viewing /media what controls the display of the right side tabs Any/Site/Album? On my forum I don't see those tabs but on my test installation I'm seeing them...

  2. Chris D

    Chris D XenForo Developer Staff Member

    I think in an earlier post you said you disabled Categories. If Categories are disabled, then all of your media is in Albums, hence no point in displaying those tabs.
  3. imthebest

    imthebest Formerly Super120

    On both installations Categories are disabled:

  4. imthebest

    imthebest Formerly Super120

    I don't know if this helps... but on my forum I have lots of media. However on my test installation there are no media yet, so the gallery is empty (just a test album, empty too).
  5. imthebest

    imthebest Formerly Super120

    I think it's related to permissions on admin.php?moderators/super/someone.123 which are different on my test installation vs. my forum. I'll check.
  6. imthebest

    imthebest Formerly Super120

    I'm confused.

    On my test installation logged in as admin I can see the Any/Site/Album tabs however logged in as a regular member I can't. So maybe it's related to permissions? However the permissions for my admin usergroup are the same both in my forum and on my test installation. The same applies to the permissions that appear at admin.php?moderators/super/someone.123

    I don't know... the only thing that comes to my mind is what I said on post #4.
  7. Chris D

    Chris D XenForo Developer Staff Member

    It's as I've said. The tabs won't show if you have either albums or categories disabled (by which I mean you have no permission to view albums / categories).

    If you have the Override Media Privacy permission then the tabs will still show.
  8. imthebest

    imthebest Formerly Super120

    I got it.

    Somehow (don't ask me why) my admin username on my test installation was listed at admin.php?user-permissions/ with the following permissions customized and set to "Yes":

    - Bypass approval when creating tags of others
    - Override media privacy

    I changed both permissions to "Not set" and then saved the changes. After doing that my admin username disappeared from the list (expected) and now I don't see those Any/Site/Album tabs anymore.
  9. Chris D

    Chris D XenForo Developer Staff Member

    On clean installs, moderators get a number of permissions automatically based on other permissions they already have.

    That is relatively new (since XFMG 1.0.0 IIRC).
    imthebest likes this.

Share This Page