1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WebDav Help

Discussion in 'General XenForo Discussion and Feedback' started by TheRevTastic, Jul 7, 2011.

  1. TheRevTastic

    TheRevTastic Well-Known Member

    Okay I just recently (like 30 minutes ago) switched from XAMPP to Zend CE for my localhost.

    I have been trying to get WebDav working again in Dreamweaver CS5.5, and I keep getting an error.

    Here is what I have put in,

    [​IMG]

    I have tried many different ways, without the :10081, with localhost and with localhost:10081.

    I just can't get it to work, any suggestions?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. TheRevTastic

    TheRevTastic Well-Known Member

    I just figured out one thing, you have to set the webdav method on in the zend server ce control panel then restart php, but still I am getting an error thrown at me saying it cant get the listing and that to make sure i have the server set up properly and to make sure i have the correct permissions on it.
     
  4. TheRevTastic

    TheRevTastic Well-Known Member

    Just an update, but I still haven't been able to figure out why it just won't work, hopefully somebody that uses WebDav and Zend Server CE can come in here and help me troubleshoot it.

    Also Brogan, the first link is helpful, but it really only seems like it is for making addon's etc when what I am using WebDav for at the moment is for styling.
     
  5. Mike

    Mike XenForo Developer Staff Member

    Try adding this to the htaccess, after the "RewriteEngine On" line:
    Code:
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
     
  6. TheRevTastic

    TheRevTastic Well-Known Member

    Didn't work unfortunately :'(.
     
  7. Mike

    Mike XenForo Developer Staff Member

    What happens if you send your browser to the admindav.php URL directly?
     
  8. TheRevTastic

    TheRevTastic Well-Known Member

    Says, "Must be in debug mode", but I never changed anything when I was using XAMPP, all I did then was put the details into the site manager on DW and it worked, plus I copied over everything from the XAMPP install to my Zend Server CE install.
     
  9. TheRevTastic

    TheRevTastic Well-Known Member

    Actually, I am a complete idiot, just realized I was trying to do it with 1.0.3, when I had it working on 1.0.2, so yeah, gotta add that piece of code into the 1.0.3 config.php. Woops, *slaps self in the face*.

    Edit: I got it to where when I go to admindav.php directly via url that it makes me put in my username and password, but still in dreamweaver it doesn't want to connect, shoots the same error at me.

    Also it only works when I have it directed at 127.0.0.1:10081/xf103/admindav.php, localhost and 127.0.0.1 by itself don't work when put in.

    Edit2: It also doesn't work for my 1.0.2 install which nothing has been changed on that before/after the move to Zend CE.
     
  10. TheRevTastic

    TheRevTastic Well-Known Member

    Alright here are some images to help you help me out a little better :).

    1.png
    2.png
    3.png

    And here is my config.php file
    PHP:
    <?php

    $config
    ['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = 'root';
    $config['db']['password'] = '';
    $config['db']['dbname'] = 'xf103';
     
    $config['superAdmins'] = '1';

    if (
    $_SERVER['REMOTE_ADDR'] == '127.0.0.1')
    {
        
    $config['debug'] = true;
    }
     
  11. Mike

    Mike XenForo Developer Staff Member

    Can you successfully enter your username and password via a browser? What do you get after that?

    Do you have the trailing slash specified?
     
  12. Luke F

    Luke F Well-Known Member

    Are you sure the server is still recognising you as 127.0.0.1? Try forcing debug mode on and/or finding out what remote_addr is really set to.
     
  13. TheRevTastic

    TheRevTastic Well-Known Member

    Still didn't work.
     
  14. Kier

    Kier XenForo Developer Staff Member

    My Dreamweaver config:
     

    Attached Files:

  15. TheRevTastic

    TheRevTastic Well-Known Member

    After recreating what Kier had in his setup (but of course changing to the stuff to reflect my server stuff) I finally got it to connect to the server, the only problem is is that it keeps saying my login stuff is wrong, when it is right!

    Even when I go to admindav.php directly via url on my localhost it won't log me in.

    Now what could be causing this? Should I just try a reinstall of XenForo?
     
  16. Mike

    Mike XenForo Developer Staff Member

    The line I gave for the .htaccess file is designed to fix that.
     
  17. TheRevTastic

    TheRevTastic Well-Known Member

    I haven't taken that line out of my .htaccess file since you gave it to me, just tried without it and still says wrong login information, then I readded it and it still says wrong login information.
     
  18. TheRevTastic

    TheRevTastic Well-Known Member

    Another quick update...

    I decided to give up on Zend Server as it started to give me other problems that I just couldn't deal with. I switched back to XAMPP.

    The thing is I installed XF on my localhost and got WebDav working for XAMPP, but for my VPS I am having the same issues I had with Zend Server CE.
     
  19. Sim

    Sim Well-Known Member

    Just to confirm that this worked for me - previously I could not log in using the web browser or Dreamweaver, and adding this line to .htaccess fixed it.

    I also had to turn on allow_webdav_methods in Zend CE "Data Handling", as per Kier's config screenshots.

    Can I suggest that more information be added to this post explaining what is required to make this work?
     
    Digital Doctor likes this.

Share This Page