• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed View new posts issue

Chris D

XenForo developer
Staff member
#1
I was writing a reply to a post in a thread. While that happened, some posts were deleted and a new post was created.

I was notified that there were new posts, but clicking "View them" didn't load the new posts.

Presumably, the fact that some posts were removed and another was added confused it.
 

DBA

Well-known member
#2
I just had a similar issue while replying to a thread. The "Messages have been posted since you loaded this page. View them?" alert appeared but I couldn't click it. I see the following error in the console.

upload_2013-6-25_13-36-43.png
 

DBA

Well-known member
#5
This just happened to me again. Replying to a thread on here and got the New Posts alert but clicking the link doesn't do anything.

Using Chrome.
 

Chris D

XenForo developer
Staff member
#6
I can replicate this with some accuracy locally now.

1) Open two different browser windows (or one normal, one incognito)
2) Login as a different user on each.
3) Start typing a message as User 1 in a thread.
4) As User 2, post one message in the same thread.
5) Wait for the Draft to save as User 1. You will get a new posts notification. This will work if you click on it. Don't click on it.
6) As User 2, post a second message in the same thread.
7) As User 1, carry on typing and wait for the second draft save.

Now, the new posts notification will not open.
 

DBA

Well-known member
#7
I can replicate this with some accuracy locally now.

1) Open two different browser windows (or one normal, one incognito)
2) Login as a different user on each.
3) Start typing a message as User 1 in a thread.
4) As User 2, post one message in the same thread.
5) Wait for the Draft to save as User 1. You will get a new posts notification. This will work if you click on it. Don't click on it.
6) As User 2, post a second message in the same thread.
7) As User 1, carry on typing and wait for the second draft save.

Now, the new posts notification will not open.
So it doesn't work if there are two or more replies?

Now that I think about it, both times this happened to me there was more than one new reply.