XF 1.5 vb4+vbseo import: problem rebuilding search index

#1
Hi we're trying to convert a very customized VB4+VBSEO forum with a few million posts to XF. Did a test import about a week ago which seems to have worked. However I didn't try to rebuild the search index until today. When I try to do that, it instantly confirms that it's done, which is kinda fishy, since it's supposed to take a long time right? Also the "recent posts" link doesn't work, and the search doesn't work, and I'm assuming that is because the search index needs to be rebuilt (yet I can't rebuild it).

What am I doing wrong here? Is it that I didn't rebuild the search index immediately?

Thanks in advance for your help, and thanks for the great product.
 

Brogan

XenForo moderator
Staff member
#2
Are you using the default MySQL search or Enhanced Search?

If the latter, have you installed and configured elasticsearch?

Are there any errors in the ACP log?
 
#3
Thanks Brogan for the reply.

Well I have all the add-ons from you including Enhanced Search, and yes it is already installed. However I just now checked and I see that I had not turned on Elastic Search. So I turned it on just now, and then tried to rebuild the search index again but still same result (immediate confirmation that it's done, yet search still doesn't work).

Regarding the ACP log, please pardon me what does ACP stand for? I see a list of logs but not able to match one with that acronym.

Thanks for your help...
 
#5
Thanks, there is nothing in the server error log. However there actually were some things there and I had cleared it because I thought it was not significant, some note about a few of the images that were imported.

Perhaps I should just start over (which I'm planning to do anyway -- another test run).

This time I guess I should be sure to not only install the enhanced search add-on first (as I did) but also enable the elastic search before the import, and then rebuild the search index immediately after the import. Do you concur? Also I'll be sure to leave in place server error logs. Thanks for the guidance...
 

Brogan

XenForo moderator
Staff member
#6
Doing a clean install is unlikely to help - as long as the add-on is installed and elasticsearch is running, you should be able to rebuild the search index.

However, the fact that it didn't also work with default MySQL search suggests the error is more low level and unrelated to the search engine.

It may be worth opening a ticket so we can investigate further - we will need an admin log in, FTP and cPanel (if available).
 
#8
FYI for this test installation/import, it's a dedicated server (cloud server) which was automatically set up and configured with ServerPilot, if that matters. Oh I've also done some tweaking of mysql (my.cnf). I don't necessarily have to go with ServerPilot for the live production server if that could possibly cause any issue. Also I'll try restoring the original my.cnf before I open the support ticket...... which okay I've now done, and restarted mysql, and oddly now when I try to rebuild the search index it outputs these errors:

----------------------------------------

An exception occurred: No response returned from Elasticsearch. Is it running? in /***************/public/library/XenES/Search/SourceHandler/ElasticSearch.php on line 1133

  1. XenES_Search_SourceHandler_ElasticSearch->_triggerFailedIndexError() in XenES/Search/SourceHandler/ElasticSearch.php at line 76
  2. XenES_Search_SourceHandler_ElasticSearch->finalizeRebuildSet() in XenForo/Search/Indexer.php at line 125
  3. XenForo_Search_Indexer->finalizeRebuildSet() in XenForo/Deferred/SearchIndex.php at line 76
  4. XenForo_Deferred_SearchIndex->execute() in XenForo/Model/Deferred.php at line 295
  5. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
  6. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 374
  7. XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
  8. XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/HtmlAdmin.php at line 131
  9. XenForo_ViewRenderer_HtmlAdmin->renderContainer() in XenForo/FrontController.php at line 639
  10. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  11. XenForo_FrontController->run() in /****************/public/admin.php at line 13

P.S. I blocked out some of my server-specific info in the first line and the last line.
 
#11
Okay I guess we're getting warmer, will study this soon, thanks!

One question for future reference, should board be turned off while rebuilding the search index?
 
Top