1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 vb4/vbseo import help

Discussion in 'Installation, Upgrade, and Import Support' started by hamish, Sep 5, 2013.

  1. hamish

    hamish Member

    Hi all, have recently moved to XF, its brilliant, what a breath of fresh air coming from vb4!!

    Anyway, I was running vbseo (a mistake it turns out imo)

    My urls were like this:

    http://www.realphotographersforum.com/general-discussion/4075-x-pro1-better-than-d800.html

    so url/node(as you guys call it)/thread id - title.html

    If that makes sense?

    to be honest, I wasn't that bothered about losing all the indexing in google, as I knew it would reindex in time. What this blinded me to was the fact that my internal linking would fall over ...

    So, I have decided well after upgrading that I would now like to set up redirects on my old thread urls ... Is this possible?

    I have searched a bit on the forums, but its a little like tumbling down a rabbit hole when you don't know what you are looking at ... and regex is a mystery at best to me!

    Thanks
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Welcome aboard!
    These might help you out. If not, @Jake Bunce is one of the re-write gurus around.
    http://xenforo.com/community/threads/help-needed-with-rewrites-from-vbseo.54812/#post-585078
    http://xenforo.com/community/threads/vbseo-links-to-xenforo.53401/#post-572671
    http://xenforo.com/community/thread...h-vbseo-help-needed-please.52211/#post-559220
     
  3. hamish

    hamish Member

    Not only did that first link provide me with the solution, you have also inadvertently introduced me to user tagging! So thanks on both counts!

    And thank you to @Jake Bunce, it seems that you sir are a genius!

    I have one more query on the subject ... I used that damned cms on vb
    With this line...

    Code:
    RewriteRule ^[^/]+/([0-9]+)-[^\.]+\.html /forum/index.php?threads/$1/ [R=301,L]
    ...old links to cms pages go to incorrect threads - i assume because of the difference in ID's

    an example http://www.realphotographersforum.com/content/945-richard-franiec-grip-rx100.html (an article about a grip for a camera)
    goes to http://www.realphotographersforum.com/forum/threads/new-idea.945/ (a thread suggesting a feature)

    is there any way to solve this?
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  5. hamish

    hamish Member

    Hi @Jake Bunce
    Just confirm for me this works for mapping vb4 cms articles to their corresponding threads?
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I don't think so.
     

Share This Page