Resource icon

vB4 Importer 3.6b2

No permission to download

Donny

Active member
Hi,

I've imported three forums from VB4 to Xen 1.1.4 now, and I've only just noticed the likes and thanks haven't imported. I understand thanks can be imported as likes somehow, I'll look at that later, but what's the score with the VB likes? I've just noticed on the latest import I've completed, that it couldn't find the database table for the likes or thanks.
Is there a way to run the importer again, and physically tell it what table to collect the likes from?

Thanks in advance for any help!
 

TnT

Member
Hi, in my version of the importer you can change the likes table in line 1744 and 1751:

PHP:
FROM ' . $prefix . 'vbseo_likes
Rerun the importer can be proplematic due to duplicate content
 

Brent W

Well-known member
Are any performance enhancements going to be made to this or will big board owners be forced to pay $150 for Slavik's importer? I'm trying to convert a forum with over 990k posts and its horrible.
 

Brent W

Well-known member
Gave up. Importer would just sit on a certain percent or refresh the page and show just a blank page while still acting like it is importing. I can't sit here for 10 hours waiting for this to finish.

Is my only solution to waste an entire day or pay $150 to get a 1 million post forum to xenForo?
 

Jake Bunce

XenForo moderator
Staff member
...a blank page while still acting like it is importing.
Is the page still loading? The process might have timed out on the server.

Adjusting the batch size might help:

http://xenforo.com/community/threads/how-fast-should-a-vb3-import-be-can-we-speed-it-up.35324/#post-401122

Or if it's a completely blank page that has stopped loading then it might be a PHP error. Try adding this line to your library/config.php file to see if that reveals any specific error message on the blank page:

Code:
ini_set('display_errors', true);
 

Brent W

Well-known member
Is the page still loading? The process might have timed out on the server.

Adjusting the batch size might help:

http://xenforo.com/community/threads/how-fast-should-a-vb3-import-be-can-we-speed-it-up.35324/#post-401122

Or if it's a completely blank page that has stopped loading then it might be a PHP error. Try adding this line to your library/config.php file to see if that reveals any specific error message on the blank page:

Code:
ini_set('display_errors', true);
Thanks, I will give this another try tomorrow with your adjustments and suggestion.
 

whynot

Well-known member
My hidden forums do not display after the transfer.
I can see their node in the ACP that they exist.
What could have happened to them?
 

Brent W

Well-known member
I made adjustments to the importer as recommended by Jake and made a few adjustments to php.ini and my.cnf to allow for longer timeouts and more memory usage.

I was able to import 1,051,000+ posts and 99,000+ threads in 46 minutes. Much much better than yesterday.

Thanks Jake.
 

Paul

Well-known member
vB can store attachments in either the db or file system. The importer will detect which method is being used. If it's a directory then it will ask you for the path.
Does this apply to avatars too? Have just tried a test import with this, and whilst some people's avatars worked correctly, most didn't and were lost in the import... :( Saying that, it didnt ask for any alternate path other than the standard one... unless i have to specify somewhere else these may be stored...

Also noticed that it wouldn't import likes - i'm guessing that's because a relatively stock vb4 doesnt have likes (i have a 3rd party likes system installed, and i'm not expecting it to pick these up!)..
 

Donny

Active member
I get the following error when trying to import the vbseo likes now, using the updated files.....

Error
  • The existing data required by the data writer could not be found.
  • Please enter a value for the required field 'thread_id'.
  • Please enter a value for the required field 'user_id'.
  • Please enter a valid name.
  • Please enter a valid message.
The table name does match, it's vbseo_likes I think.
 

speedway

Well-known member
Gave up. Importer would just sit on a certain percent or refresh the page and show just a blank page while still acting like it is importing. I can't sit here for 10 hours waiting for this to finish.

Is my only solution to waste an entire day or pay $150 to get a 1 million post forum to xenForo?
You could take a look at DigitalPoints original version but you would have to customise it to your solution. Thats the path I am taking with my 856K forum, haven't got $150.00 to spend on a one time thing.
 
Top