1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

vB 3.8 -> XF Import Error: "Please enter a valid title."

Discussion in 'Installation, Upgrade, and Import Support' started by projectego, Oct 7, 2010.

  1. projectego

    projectego Active Member

    Hi folks,

    I feel like a bit of an idiot, but this one has left me scratching my head. I'm attempting to migrate over to XF on this forum. I've installed XF in the same database as my vB installation and attempted an import - sadly, no dice. I then went and created a new database and attempted to import the vB data from my old database to the new XF one - still, no dice.

    I get the same error message over and over again; I can only assume I'm missing something glaringly obvious.

    I've included two screenshots of my problem; basically, I click on the first step of the import procedure, which is "Import User Groups", but, when I do, I'm greeted with the error message in screenshot 2, "Please enter a valid title." However, for the life of me, I cannot find a single area to enter anything. I must either be losing my mind (more than likely) or perhaps this is an easily fixable bug?

    I would appreciate any and all help. Thank you very much in advance.


    Attached Files:

  2. projectego

    projectego Active Member

    Nevermind. I believe I have found a fix. If any of you should encounter this problem - please verify that your vB usergroup titles do not have any strange characters in there; removing said-characters worked for me.
  3. SneakyDave

    SneakyDave Well-Known Member

    That might be a problem for me, as most of the members of my user groups are strange characters. ZING!
    projectego likes this.
  4. projectego

    projectego Active Member

    Lol! Very good Dave. Very good. :p
  5. Alex

    Alex Active Member

    Thanks for this was getting the same error when I was doing it, will now go and check this, can you just comfirm what you mean by strange characters please?
  6. projectego

    projectego Active Member

    Pretty much anything that is not alphanumeric. By this I mean: #*&%£ etc.
  7. Alex

    Alex Active Member

    Must be something else giving me the error then as all the Usergroup names are alpha characters, back to the drawing board then
  8. silendreamer

    silendreamer Active Member

    @projectgo .. I just noticed that many of your pages that were indexed in Google, are no longer working or are being redirected to something totally different.

    For eg.


    This page is indexed in Google from your vBulletin installation. The title of the thread was "Digging"

    It is now redirecting to http://projectego.net/forums/threads/random-funny-d.4845/

    The title of this thread is "Random Funny"

    Note that the thread ID in both the cases is 4845

    I had the same thing asked as a question here -- http://xenforo.com/community/threads/question-about-import-from-vb3.5541/

    I am now wondering if it is a good idea for me to convert my vbulletin to xenforo as most of my traffic is from Google and if this is the case, then I might lose a lot of that traffic.
  9. projectego

    projectego Active Member

    Another problem I had was that I had one usergroup that - and it's quite bizarre - had no title at all. It was like a dummy usergroup, or something. I can only assume it was made by mistake by another administrator but deleting that usergroup also helped remedy the situation.
  10. projectego

    projectego Active Member

    I'm actually going through as many of my 20,000+ indexed pages one-by-one (*sigh*) and adding 301 redirects manually to my .htaccess file. It could take some time...fortunately, I'm paying someone to do it for me.

    I believe that, provided you are using the default vB URL structure (showthread.php?=6536, etc.) then XF will automatically 301 redirect your old vB URLS to the newer XF equivalents. This is not the case with vBSEO URLs though, and the advice given here: http://xenforo.com/community/threads/feedback-wanted-redirects-for-vbseod-urls.5098/

    ...did not work for me. It's a real shame, too, because I've installed XF three times now on three different websites and, aside from the one I imported earlier today, they've worked smashingly. My community is mostly very disappointed about the move, but it is my own fault for migrating over to beta software; the "Like" system doesn't work for me, neither does the ability to upload avatars (for 50% of my community anyway) and for whatever bizarre reason, I'm unable to update certain options of my profile. To give you an idea: I can change my user title, but I cannot opt to select "male" as my gender - so unless the software is flat-out calling me a liar and is refusing my choice, I don't know what could be the problem.

    My advice would be: wait until XF goes gold before you even consider migrating over. I was very much looking forward to switching over to XF on my Devil May Cry and Resident Evil forums; I certainly won't be doing so now. A real shame as I will have three of my five XF licenses sitting there collecting dust until the software goes gold.

    With that said, on my "fresh" install forum(s), it works superb. Just think twice about making the switch now.
  11. silendreamer

    silendreamer Active Member

    Well said projectgo. I really feel sorry about your move and users not being happy.I was very speculative about the same, and after hearing your experience, would surely not try to migrate without testing it completely on a test server.

    By the way have you tried the redirect script?
  12. projectego

    projectego Active Member

    Personally, despite my community not being at all happy about the switch (which I was almost certain most would be the case simply because they had become accustom to the old vBulletin style and are reluctant to give XF a chance), I'm very happy with it - despite the bizarre problems that are still cropping up. I found a way to fix the problem with users not being able to upload avatars but, sadly, the fix is not an especially good one.

    Pray tell - any chance you could link me up to the redirect script? I've tried Kier's one, which I believe was intended for forums not using vBSEO; and I've tried the one that the one that's included in the link above but I've had no luck whatsoever.

    At this point, I would pay for a working 301 redirect script that would convert my old vBSEO URLs to the newer XF ones. This is really going to hurt my rankings if nothing changes but, honestly, it's my fault for migrating over to beta software. It's such a shame that my vB -> XF has turned out so damn glitchy. I know I said it in a previous post, but XF is working like a charm on my Styles website.

Share This Page