1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Using Spam Cleaner

Discussion in 'Troubleshooting and Problems' started by DaveM, Sep 23, 2015.

  1. DaveM

    DaveM Well-Known Member

    I have just tried using the spam cleaner options on the following thread

    upload_2015-9-23_12-30-35.png

    Selected spam option at the bottom of thread

    upload_2015-9-23_12-31-38.png

    Select Clean Up option and I get the following

    upload_2015-9-23_12-32-29.png

    It bans the user but does not remove the thread in question
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That just means there were no other users with the same IP address.

    The other actions have been carried out.
     
  3. DaveM

    DaveM Well-Known Member

    I was just wondering why it never removed those threads, but I have now tweaked it so it should move the threads, thanks for your reply on this
     
  4. drastic

    drastic Well-Known Member

    Where is the Spam cleaner now?

    upgraded to latest version and it's no where to be found. I'm using the default style and have 1000+ messages selling prick pills.
     
  5. wang

    wang Well-Known Member

    The upgrade has not removed it. If you switch to the default style, can you see it?
     
  6. drastic

    drastic Well-Known Member

    Why doesn't it give me option to SPAM clean on this guy? It does for everyone else.

    WEFSDF.png
     
  7. AndyB

    AndyB Well-Known Member

    drastic likes this.
  8. drastic

    drastic Well-Known Member

    Thanks, but I need to clean this up first.
     
  9. AndyB

    AndyB Well-Known Member

    drastic likes this.
  10. drastic

    drastic Well-Known Member

    Really random that the spam cleaner isn't appearing. Totally unsure why.
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Check the criteria.

    I suspect the member does not meet it.
     
    drastic likes this.
  12. drastic

    drastic Well-Known Member

    @AndyB - the post delete addon worked GREAT!!!

    Thanks a million!!
     
    AndyB likes this.
  13. drastic

    drastic Well-Known Member


    The member had 100's of posts full of spam links and pics. I checked my own perms, everything OK for super mod/admin. Not sure what I did wrong.

    Anything else I can check to make sure this doesn't happen again? Or any specific settings I SHOULD have that I may not know about (or did wrong)?

    Thanks!!
     
  14. Chris D

    Chris D XenForo Developer Staff Member

    Brogan is talking about the spam cleaner criteria which dictates which users can or can't be spam cleaned.

    Search for "spamUserCriteria" using the Admin CP search.
     
    drastic likes this.
  15. AdamG2

    AdamG2 New Member

    Follow-up question about the spam cleaner. I have a user who meets the criteria for spam cleaning in the ACP. I used spam cleaner on him and the threads are hidden, but I don't see him getting banned despite that option being checked in the ACP. If I look at his user account he still shows valid, and the banned usergroup isn't checked. I can see that spam cleaner was run against him in the log. Am I missing something?
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    Was the option to ban checked when the spam cleaner was run?

    upload_2016-2-2_18-16-23.png
     
  17. AdamG2

    AdamG2 New Member

    Yes. We also have it set as a default option in the ACP.
     
  18. Brogan

    Brogan XenForo Moderator Staff Member

    The default options can be overridden on a per use basis.

    Are you able to consistently reproduce it?

    It works for me when spam cleaning a user with the ban option checked.
     
  19. AdamG2

    AdamG2 New Member

    We just converted. I will wait for the next spammer and try to reproduce
     

Share This Page