• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Usergroup Promotions keep reverting

Eoj Nawoh

Active member
#1
Hello All,

I'm a bit confused with this User Group promotion problem I'm having. I'm not sure if it's my install, XenForo or a specific addon, but perhaps I'm missing something obvious.

We use Steam Login as an addon, when those users create account is sets them as "Associated" with a Steam account. We have a usergroup promotion that takes anyone with Associated and adds them to a usergroup called "Steam Registered".

Yet here's the problem:


It keeps reverting it for our active members. Users that haven't logged in at all don't have this issue. Any advice? Even if it's just adding them and just ignoring them indefinitely.

Any advice or help would be appreciated!
 

Brogan

XenForo moderator
Staff member
#2
What criteria do you have for the promotion(s)?

I suspect there is conflicting criteria, such as "is not a member of...", which is causing the promotion to flip flop.
 

Rob

Well-known member
#3
Yeah, I've done this before and had a constantly switching promotion. It is caused when a promotion adds new criteria that invalidates the original promotion, so that when a user is promoted, they are no longer eligible for the original promotion criteria and are hence stripped of the promotion (demoted) - and round and round it goes.

Brogan likes flip flops :)
 

Eoj Nawoh

Active member
#4
What criteria do you have for the promotion(s)?

I suspect there is conflicting criteria, such as "is not a member of...", which is causing the promotion to flip flop.
Yeah, I've done this before and had a constantly switching promotion. It is caused when a promotion adds new criteria that invalidates the original promotion, so that when a user is promoted, they are no longer eligible for the original promotion criteria and are hence stripped of the promotion (demoted) - and round and round it goes.

Brogan likes flip flops :)
Thanks for the quick response! Yes, there was originally that criteria to prevent it from running on people twice (I misunderstood it). Once, I realized this problem, I turned it off, it's been a day or two since I removed that.
 

Rob

Well-known member
#5
So, if this is still happening can you post your criteria as brogan has suggested so the problem can be identified?
 

Eoj Nawoh

Active member
#6
Details:
Promotion is Active

Add User to User Groups: "Steam Registered"

Criteria is only: "Steam state is: Associated"

And that's it. As I said before, it could be related to the addon, but was confused as it's clearly not removing these people's association with Steam.
 

Martok

Well-known member
#8
If you are sure that there are no other user group promotions that could conflict with this one, then it could be a problem with the Steam Login add-on that associates users with a Steam account. I don't know how it works but if it is unassociating users from a Steam account (e.g. when they are logged out) then that would be the issue.

It's worth looking into that possibility if you are positive that no other user group promotions could be interfering.
 

Brogan

XenForo moderator
Staff member
#9
I'm sure I have dealt with an issue with the steam log in before related to promotions (unless my age is starting to affect my mind...).

A way to test it would be to change the criteria to something unrelated to the steam log in and if it doesn't keep swapping then it's likely the add-on.
 

Eoj Nawoh

Active member
#11
Alright, thanks I'll give that a shot.



Edit: If it does prove to be true, would anyone have a suggestion as to have users with Steam added to Steam Registered?