1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Usergroup cant edit post

Discussion in 'Troubleshooting and Problems' started by bogus, Jan 17, 2011.

  1. bogus

    bogus Guest

    I have set up the time limit to edit a post for a separated Usergroup to unlimited in "Forum Permissions". But after i replied and try a second later to edit the post i get this.

    And, am i right that i just have to set Userrights to a Category and the childs can be inherit?
  2. Mike

    Mike XenForo Developer Staff Member

    That error indicates the time limit is set to 0, not unlimited. Double check that.
  3. bogus

    bogus Guest

    User is in Group Supp2 (example group)
    User Group Permissions - Supp2 (example group) - Forum Permissions - Time limit on editing/deleting own posts (minutes): Unlimited
    Node Permissions - Admin & Supporter Category - Supp2 (example group) - Forum Permissions: Unlimited
    Still can´t edit his own post. Edit post by self - set in both to allow. This Usermanagment scares me ;)
  4. Decent60

    Decent60 Well-Known Member

    Have you tried rebuilding caches, such as permissions and such?
    When I upgraded to BETA 6, one of the admins couldn't see the moderation panel, even though both the Admin usergroup, moderaton and the Administrator group all had the proper settings so he could see it. I simply just went in, hit save and it worked just fine.
  5. bogus

    bogus Guest

    I imported them from vb and rebuild all. but i have serious problems with the Userrights.
    Some users that I have added to a group for an intern Forum, can see this, some of them cant, only if i update this Usergroup again they also can see this Forum, what sounds weird to me.

    Another Problem. I just moved a User from this Test Group into his old Group.
    All other Users in this Group can still see the intern Forum, but this single User, i just moved a minute ago is not able to see the intern Board anymore.
    I dont know if i am to stupid for this or if there is a serious problem in there.

    Ok i found out what the problem is, in my board. Dont know if others have the same.
    After i moved the User back to his old Group i had to rebuild the users cache (that cant be the normal way)
    If i am testing the permission of that User, i am just able to edit new posts but not the old ones
    It would be nice if one of the responsible ones could take a look to this. Maybe also on my board
  6. Mike

    Mike XenForo Developer Staff Member

    If you send me admin CP access, I can look into the first issue. (I need to know the name of the user with the issue.)

    If you send me FTP access as well, I can look into the permission issues you brought up at the end. I also need to know specific users with problems.
  7. bogus

    bogus Guest

    Hmm i have setup a Testboard and tested exactly the same as i did it in my live board. On the Testboard all worked fine. Maybe it has to do with the importer? Or it is maybe any Addon? I don´t know.
  8. Mike

    Mike XenForo Developer Staff Member

    I have your details, but haven't had a chance to look into it yet.
  9. bogus

    bogus Guest

    I thought so. To be honest i really have no clue what the problem is. Its all ok at the testforum but as soon as i do the same in my liveboard it does only work if i rebuild the users cache. Weird.
    Well just leave me a "pm" as soon as u got a moment to take a look. Thanks Mike

Share This Page