• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Use uncompressed JavaScript files

Alluidh

Well-known member
#1
Hi

In Debug Mode is an option
Use uncompressed JavaScript files
If you are running a development copy of XenForo with the full, uncompressed versions of the XenForo JavaScript files, disable this option.
The default is disable and for me it is ok, because it has to be
If you are running a development copy of XenForo with the full, uncompressed versions of the XenForo JavaScript files, enable this option.
Right?
 

Kier

XenForo Developer
Staff member
#2
Yes, it should be disabled.

The only people who should enable that option are those who know how to change the file structure to actually allow the system to use the uncompressed JS.
 

Alluidh

Well-known member
#5
This is your text
Use uncompressed JavaScript files
If you are running a development copy of XenForo with the full, uncompressed versions of the XenForo JavaScript files, disable this option.
The default option is "disabled". So if you want to run a development copy of XenForo with the full, uncompressed versions of the XenForo JavaScript files, for me you need to enable this option. Or not?
 
R

ragtek

Guest
#8
Hm, that's a little bit strange.

If i want to use the uncompressed, i have to:

1. Overwrite js/xenforo with xenforo.full content
2. Activate the option

right?

Why not include xenforo.full instead of /xenforo in the template?
This will "break" and i would need to do this again and again on every xf update.

:)( just happened to me now after the update to beta2)