1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Url change - cannot login

Discussion in 'Troubleshooting and Problems' started by 3v1LD34D, Oct 4, 2014.

  1. 3v1LD34D

    3v1LD34D Member

    Hi,

    I recently changed my main url for the forum, changing the options in
    'Home>Options>Basic board Information'. I have a htaccess at the root which
    forwards to the forum (which i have corrected).

    However unless i use the old url i cannot log in as any user, the error being
    'The requested user 'fictitious-user' could not be found'.

    I have also removed the # from ' RewriteBase /Forums' in the htaccess for xenforo
    and updated the installation folder as shown above, recommended on the forum to
    fix this issue... hasnt made any difference.

    :(

    Is there any other options i should be checking, if not its time to backup the templates/style
    and start again?

    :eek:

    Much appreciated!!
    3v1L
     
    Last edited: Oct 4, 2014
  2. Mike

    Mike XenForo Developer Staff Member

    I browsed around your forum and everything appears to be working correctly. Are you still having an issue?
     
  3. 3v1LD34D

    3v1LD34D Member

    Nope, its like my password is incorrect but it isnt... change to the old url and its fine.

    :(

    Clear cache and temp files as usual for troubleshooting purposes, use both chrome and IE just to be sure...
    can reproduce this on different pcs. I can create you an admin account if you wanted to see.
     
    Last edited: Oct 4, 2014
  4. Mike

    Mike XenForo Developer Staff Member

    What's the new URL then?

    Is it just when logging in? What's the actual URL you're on and actual message? If you disable all add-ons does it still happen?
     
  5. 3v1LD34D

    3v1LD34D Member

    Hi,

    As attached.
    Thanks, i appreciate the help... i was starting to get the impression that this level of change
    would require a fresh install... trying to be optimistic and perhaps thought this might help
    someone else if they are in a similar situation.

    New
    http://immortals-eu.com
    Old
    http://immortals.darkhosts.co.uk/

    Example.jpg
     
    Last edited: Oct 4, 2014
  6. 3v1LD34D

    3v1LD34D Member

    And thats for the admin page, both with addons disabled.

    Example2.jpg
     
  7. Mike

    Mike XenForo Developer Staff Member

    That's a different error than what you mentioned initially. :)

    So you've moved servers then? In this case, you've moved from a server running PHP 5.3 or newer to a server running PHP 5.2. PHP 5.2 does not have support for the more secure passwords that we use with 5.3+ automatically. You really should make sure that you're running at least PHP 5.4 these days (PHP 5.2 has been unsupported by the PHP group for years). Your host likely provides multiple PHP packages.

    If you can't switch to PHP 5.3+, you will need to do a lost password request.
     
    3v1LD34D likes this.
  8. 3v1LD34D

    3v1LD34D Member

    Ah ok,

    You've given me the clue i needed, they are all on the same server (as far as i know) ... but each domain has its own PHP setting...
    it used to (lol, as far as i know) use the same PHP version for all of them... or at least i bought a new domain and it hasnt picked anything useful.

    Waiting for the settings to take place and i will retest.
    Example3.jpg
     
  9. 3v1LD34D

    3v1LD34D Member

    All working and no password reset required!!
    Updated the title so people might be able to pick it up themselves.

    (y)

    Well done that man, made my day!
    3v1L,
     

Share This Page