1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Upgrade process don't start, just install

Discussion in 'Installation, Upgrade, and Import Support' started by BelMa, Jan 22, 2016.

  1. BelMa

    BelMa Member

    Hello there,

    I've a test board running XF 1.2, so I've tried to upgrade to last 1.5.x available.

    After downloading and uploading the upgrade package, I've started the process typing www.myboard/install as stated in the upgrade procedures, but no upgrade process here, just the fresh installation dialog.

    What am I doing wrong ?

    Thanks in advance.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Did you upload the full package or the upgrade package?

    Does the library/config.php file still have the database connection details?

    Is your install-lock.php file in place in /internal_data?

    Do the /data and /internal_data directories still contain all uploaded attachments and avatars?
  3. BelMa

    BelMa Member

    Thanks for the quick reply, Brogan.

    I've uploaded the upgrade package, and config.php is OK.

    I've removed instal-lock.php because I've been asked to do so at some point.

    /data/ and /internal_data directories are the same that I've before the upgrade process, nothing has been changed there.

    Best regards.
  4. Jeremy P

    Jeremy P Well-Known Member

    Removing install-lock.php would cause this, I believe.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    That file denotes an active installation so it should never be removed.

    You can manually recreate it with the following content:
    <?php header('Location: ../index.php'); /* Installed: Mon, 07 Dec 15 16:29:25 +0000 */
  6. BelMa

    BelMa Member

    Seems that something has been wrong in the upgrade process...maybe was my fault.

    So how can I restore it ? This file is not in the upgrade package, nor in the full installation one.
  7. BelMa

    BelMa Member

    Ok, I'll try. Thanks one more time.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    The file is generated automatically during the install process.

    I edited my post above to show how to manually create it.
  9. BelMa

    BelMa Member

    Done ! Upgrade process just started.

    Thanks a lot, Brogan, very kind.

    Best regards.

Share This Page