• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Upgrade problem: The required PHP extension GD could not be found

#1
I was running 1.01 just fine, but when trying to upgrade I get the error below. I did try re-extracting and re-uploading a few times just in case it was a bad upload, but no go.

Upgrade System
The following errors occurred while verifying that your server can run XenForo:

The required PHP extension GD could not be found. Please ask your host to install this extension.
Please correct these errors and try again.
 

Brogan

XenForo moderator
Staff member
#2
You will need to install that extension, it has been a requirement for some time.

XenForo System Requirements
  • PHP: 5.2.4+
  • MySQL: 5.0+
  • PHP extensions: MySQLi, GD (with JPEG support), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype
  • PHP safe_mode off
Download the requirements test script.

Speak to your host and they should be able to install it for you.
 

Mike

XenForo developer
Staff member
#3
Did you move servers after you did an install? (Or did the server configuration change?) The install checks that requirement too, so you obviously passed it then. It's important for avatars and attachments.
 
#4
I haven't moved servers and haven't changed the configuration. All versions of XenForo have installed just fine, up to 1.01 which I did the day it came out. I'm using godaddy for hosting, so I suppose it's possible they have changed something on their end, although it says I have "PHP 5.x" enabled there (and there isn't anything I can do to change or configure that anyway).
 

Brogan

XenForo moderator
Staff member
#5
It would be unusual for your host to remove an extension which is already installed, but not unheard of.

Someone last week had exactly the same issue, I don't recall the host though.