XF 2.2 Upgrade from 1.5 to 2.2.5

rosal

Active member
What is the best method to upgrade from 1.5 to last xenforo version (2.2.5).

For now i have done this
  • Create a duplicate test site
  • Removed styles and all addons from 1.5

Now i need some directions
- I have arround 1.000.000 messages board so i read in this forum there is a way by cli command to update, can i do this to upgrade from 1.5?
How can i do this?

Need some advices!

Thanks to all.
 

rosal

Active member
So far so good the system recommended doing by cli and i do-it without problems.

Just one warning, but completed with success.
libpng warning: Interlace handling should be turned on when using png_read_image
Any recommendations to this warning?


Now next step:
After doing this all my root directory have so much files from olders versions, so what is the best way to put only clean 2.2.5 files and remove the old ones.

Can i delete all the files, and send a new files from the xenforo_2.2.5_xxxxxx_full and then just edit the src/config.php with the database credentials?
 

Brogan

XenForo moderator
Staff member
Any recommendations to this warning?
That's a server setting - your host will be able to assist.

what is the best way to put only clean 2.2.5 files and remove the old ones.
 

rosal

Active member
php cmd.php xf:legacy-cleanup

That command only clean the directory i executed right?

Dont clean other folders outside right?
Asking this because iam runing the tests in same account domain but in another directory.
 

Brogan

XenForo moderator
Staff member
I haven't used it but I presume it will only affect files related to the installation from within the directory it is run.

You can confirm by asking in the resource thread.
 

rosal

Active member
Now next step:
Can i delete all the files, and send a new files from the xenforo_2.2.5_xxxxxx_full and then just edit the src/config.php with the database credentials?
I have done this deleted all files and folders and extracted the full version to this directory and worked perfected.
I have used the old files and folders internal_data and data.

This can be a problem in future?
For now its working ok without errors
 
Top