Upgrade b2 to b3 problem

kuyenmotdivad

Well-known member
Hi,

I get this when I try to upgrade from beta 2 to 3.

Code:
Server Error

apc_store() [<a  href='function.apc-store'>function.apc-store</a>]: Potential  cache slam averted for key 'freaksdata_options'
XenForo_Application::handlePhpError()
apc_store() in /home/xxxx/public_html/community/library/Zend/Cache/Backend/Apc.php at line 112
Zend_Cache_Backend_Apc->save()[/B]in[B]/home/xxxx/public_html/community/library/Zend/Cache/Core.php at line[B]390[/B]
Zend_Cache_Core->save()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/Model/DataRegistry.php[/B]at line[B]169[/B]
XenForo_Model_DataRegistry->set()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/Model/Option.php[/B]at line[B]492[/B]
XenForo_Model_Option->rebuildOptionCache()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/Model/Option.php[/B]at line[B]880[/B]
XenForo_Model_Option->importOptionsAddOnXml()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/Model/Option.php[/B]at line[B]775[/B]
XenForo_Model_Option->importOptionsDevelopmentXml()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/CacheRebuilder/ImportMasterData.php[/B]at line[B]37[/B]
XenForo_CacheRebuilder_ImportMasterData->rebuild()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/ControllerHelper/CacheRebuild.php[/B]at line[B]26[/B]
XenForo_ControllerHelper_CacheRebuild->rebuildCache()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/Install/Controller/Upgrade.php[/B]at line[B]181[/B]
XenForo_Install_Controller_Upgrade->actionRebuild()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/FrontController.php[/B]at line[B]303[/B]
XenForo_FrontController->dispatch()[/B]in[B]/home/xxxx/public_html/community/library/XenForo/FrontController.php[/B]at line[B]132[/B]
XenForo_FrontController->run()[/B]in[B]/home/xxxx/public_html/community/install/index.php at line 17
 
F

Floris

Guest
Remove the apc cache details from config.php and try again.
 

Mike

XenForo developer
Staff member
This is potentially known issue using APC for caching (via config.php; opcode caching is fine). We can only recommend not using it at this point.
 

Mike

XenForo developer
Staff member
You'll basically need to turn it off fully. The problem is that turning it back on may lead to out of date caches. (That is a near impossible problem to workaround.)
 

Deebs

Well-known member
Interestingly I have upgraded my b2 testboard to b3 with no errors whatsoever with APC caching turned on. Big thumbs up Mike, a much improved process over the b1 to b2 upgrade. Not sure if this was in the previous upgrade but I do like the additional dots being presented as some form of progress.
 
F

Floris

Guest
Just a FYI.

I run Ubuntu LAMP setup with APC and Beta 2 to Beta 3 upgrade went fine. No errors. And I left APC details in the config.php.

Let's hope it keeps going this smooth.
 
Top