Not planned Update to latest third party emoji groups!

Chromaniac

Well-known member
JoyPixels 6.0 is out. Unicode 13.0 emojis have arrived. Twemoji is also updated with the new emojis I believe. I searched for a few in the smiley panel and it does not look like the new ones (boomerang for instance) are available there. Would be great if XF2.2 launch with these updates.

This should help in cases where users on updated Android/iOS builds using these new emojis are visible to people on outdated builds. Though I am not sure how XenForo handle emojis it does not recognize.

Here are a few boomerang emojis: 🪃🪃🪃🪃🪃 Preview does not show even the boxes which are visible in editor.
 
Upvote 0
This suggestion has been closed. Votes are no longer accepted.

Brogan

XenForo moderator
Staff member
It's not necessary to make suggestions such as this.

Third party libraries are routinely updated.
 

Chris D

XenForo developer
Staff member
And many things need to be investigated such as potential license agreement changes, including in the case of JoyPixels, paying to renew licenses etc. so it's a bit of a process but one that is routinely monitored for various updates.
 

Chris D

XenForo developer
Staff member
I should probably also note...

There's actually a little bit of separation here that isn't quite clear.

We might be able to update the graphics in use to v6 in fairly short order because it's just a case of downloading those and replacing the existing ones.

But the emoji displayed in the menu which are searchable actually require their Emoji Toolkit to be updated:

It's still on version 5.5 though right now.

So even if we updated the graphics to version 6.0, the latest Unicode 13 emojis won't be searchable or replaceable from the native ones until that toolkit is updated. There's no license agreement concerns there though, ironically.
 

Chromaniac

Well-known member
Another question about this. Please move if it would be considered as a bug.

So my phone now has support for emoji 13. And I decided to test it out on my installation.

Since the new emojis are not part of third party emoji kits, I changed forum setting to switch to native emoji support so that the new emojis would at least appear on updated iOS and android devices.

Weird thing is that latest activity page does show the newer emojis like 🤌 (probably would not appear here because of this weird behavior) but the post content doesn't.

RHnKOQO.png
 
Last edited:

Chris D

XenForo developer
Staff member
🤌

We've updated to version 6 of the JoyPixels toolkit now which we weren't able to do until they actually updated the repo. Turns out they did this a month later, in August, and I missed it.

I think what you're describing is expected but should be sorted now.
 

Chromaniac

Well-known member
i am still a bit confused though. if xenforo is set to use native emojis... shouldn't new emojis appear irrespective of support in third party libraries if the browser is capable of showing those emojis, in post content! (it does work in latest activity template but not thread view template!)

looking forward to emoji 13 support in rc3 through third party emoji sets! i assume this would also somehow enable the new native emojis as well :confused:
 
Last edited:

Chromaniac

Well-known member
And they now work with native emoji enabled after updating to 2.2. So even native emoji visibility is dependent upon the third party toolkit... 😛
 
Top