1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot Reproduce unspecified error

Discussion in 'Resolved Bug Reports' started by Adam Howard, Sep 18, 2013.

  1. Adam Howard

    Adam Howard Well-Known Member

    At least that is what I think it said when I saved a post. I've seen it a few times, it happens very quickly.

    This is happening on XenForo.com
     
  2. Adam Howard

    Adam Howard Well-Known Member

    Screenshot from 2013-09-18 11:49:53.png

    ^^ In the above screen shot. You know how it says, "Your changes have been saved". Same box, but will randomly read "unspecified error"
     
  3. Mike

    Mike XenForo Developer Staff Member

    I'd need to see network tab and the actual response data to do any debugging on this. "Unspecified error" really just means no message was returned, though I don't see why that would happen.
     
  4. tyteen4a03

    tyteen4a03 Well-Known Member

    This has happened to me too, and I've only ran into it once.
     
    Adam Howard likes this.
  5. Mike

    Mike XenForo Developer Staff Member

    Does it redirect as expected?
     
  6. tyteen4a03

    tyteen4a03 Well-Known Member

    Nope, just stays on the page. I've made a bug report about this before, but was unable to reproduce it again ever since.
     
  7. Adam Howard

    Adam Howard Well-Known Member

    @Mike It happens so rarely I think it has only happen 3 - 4x so far (in a months time). So I'm not surprised @tyteen4a03 almost never sees it.
     
    Last edited: Sep 20, 2013
  8. Adam Howard

    Adam Howard Well-Known Member

  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    He'll need a network trace to properly debug this.
     
  10. Adam Howard

    Adam Howard Well-Known Member

    A network trace? You mean a trace route?
     
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    No, from your browsers' Network tab.

    Screen Shot 2013-09-23 at 3.47.51 PM.png
     
    SneakyDave likes this.
  12. Adam Howard

    Adam Howard Well-Known Member

    I'm trying to figure out how I would generate that and submit that in Firefox.
     
  13. Jeremy

    Jeremy XenForo Moderator Staff Member

    Firebug.
     
  14. Adam Howard

    Adam Howard Well-Known Member

    So, wait... How am I going to get this as it happens? I'm not going to be browsing with firebug open all the time.
     
  15. tyteen4a03

    tyteen4a03 Well-Known Member

    Open Firebug immediately after you see the error.
     
    Adam Howard likes this.
  16. Adam Howard

    Adam Howard Well-Known Member

    That's not how Firebug works though. I'll have to refresh the page in order for it to show me anything in network.
     
  17. Jeremy

    Jeremy XenForo Moderator Staff Member

    Then keep firebug open and as small as possible until it happens.
     
    SneakyDave likes this.
  18. Adam Howard

    Adam Howard Well-Known Member

    And will a screen shot do? Because I do not know if there is away to export that data.

    (I'm seriously not trying to make this into a big deal. I just do not understand why you want the network read out. )
     
  19. Jeremy

    Jeremy XenForo Moderator Staff Member

    Network read out includes things such as data submitted, URL and response. That data is extremely useful.
     
    SneakyDave and Adam Howard like this.
  20. Mike

    Mike XenForo Developer Staff Member

    I need the network read out because I need to see the exact URL, the response code, and what was returned by the server (and possibly the data that was sent). It's unlikely that any errors are being logged, so the data generally appears to "fit", but I need to see exactly what's going on to possibly have any idea where to start. (Just to make it clear, you'll need to expand the correct network connection and possibly screenshot a few tabs of it.)

    Note that you can probably have Firebug on but minimized. I believe it should still record things.
     
    Adam Howard likes this.

Share This Page