• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

MG 1.1 Unable to upload video's

#1
Unable to upload video's, just display's an error box at the very end of upload process, goes through the entire 1%-100% etc. I thought I had everything configured correctly? What am I missing?

ffmpeg 0.8.17-4:0.8.17-0ubuntu0.12.04.1
libavutil 51. 22. 3 / 51. 22. 3
libavcodec 53. 35. 0 / 53. 35. 0
libavformat 53. 21. 1 / 53. 21. 1
libavdevice 53. 2. 0 / 53. 2. 0
libavfilter 2. 15. 0 / 2. 15. 0
libswscale 2. 1. 0 / 2. 1. 0
libpostproc 52. 0. 0 / 52. 0. 0
 

Chris D

XenForo developer
Staff member
#2
Are you running MG 1.1.6? Did you upgrade to version 1.1.6(a) when it was released or did you stay on 1.1.6? A fix was rushed out to address this problem.

I'm not totally clear on what version of FFmpeg you are running from that output. There's usually a line at the top of he output which has the copyright and release year.

Has transcoding videos ever worked?
 
#3
Yes, running MG 1.1.6(a)
The following error occurred
There was a problem uploading your file.

My host said I am running most current ffmpeg... "Yes, it's the default version for ubuntu 12.0.4:"

Not sure transcoding videos ever worked as I personally never use it, just have to check into it when customers complain that something doesn't work. ;-)
 

Chris D

XenForo developer
Staff member
#4
I would expect the "default version for ubuntu 12.0.4" to be pretty old. In fact, it may confirm my suspicion about the FFmpeg version you're using. The output does seem to suggest "ffmpeg 0.8.17" but it wasn't really in the format I was expecting.

If it is indeed 0.8.17 then that's likely too old. If you go to Admin CP > Applications > Gallery Options > Video Options and click "Save Changes" do you get an error? We check the FFmpeg version at save time so usually we would display an error if you're using a really old version.

Besides all that, a potential solution may be to get your host to use one of the static builds here:
http://johnvansickle.com/ffmpeg/

It's worth noting that these static builds are recommended by FFmpeg themselves. It should be just a case of downloading, extracting the files, and copying the ffmpeg binary to a location on the server and either updating the ffmpeg symlink or updating the path to FFmpeg in the Gallery Options.
 

Mike

XenForo developer
Staff member
#5
The error may also simply be upload related. Can you test with a video of similar file size that doesn't have to be transcoded? (I'm presuming this has worked before.)
 
#6
If it is indeed 0.8.17 then that's likely too old. If you go to Admin CP > Applications > Gallery Options > Video Options and click "Save Changes" do you get an error? We check the FFmpeg version at save time so usually we would display an error if you're using a really old version.
No error on save.
 

Chris D

XenForo developer
Staff member
#8
Did it create the thumbnail without an issue?

It was failing at the bit where I thought the thumbnail creation would be happening, but if it is creating thumbnails without issue then it's unlikely to be that.

Can you provide information on the video you are uploading which fails? What size is it? What format is it? If you could let us know the specific ffmpeg version that might still be relevant.
 
#9
Yes, it created thumbnail without an issue. (.mpeg)
The video that fails is in .avi format 327 MB
How do I find out what ffmpeg version I have?
 

Chris D

XenForo developer
Staff member
#10
If you type "ffmpeg" at a remote shell the first line should give you its version number or git build number and the copyright year.

That's quite a large file so it's possible that it is taking too long for the server to process. It might be worth disabling the Flash uploader and trying again. Sometimes this will show a more reasonable error.
 

Chris D

XenForo developer
Staff member
#12
Get hold of the original video and try it yourself to prove whether it's a localised thing or not.

If you can repeat the same issue, try uploading it without the Flash uploader enabled to see if you get a more detailed error.
 
#15
If you type "ffmpeg" at a remote shell the first line should give you its version number or git build number and the copyright year.

That's quite a large file so it's possible that it is taking too long for the server to process. It might be worth disabling the Flash uploader and trying again. Sometimes this will show a more reasonable error.
ffmpeg version 0.8.17-4:0.8.17-0ubuntu0.12.04.1, Copyright (c) 2000-2014 the Libav developers
built on Mar 16 2015 13:26:50 with gcc 4.6.3
The ffmpeg program is only provided for script compatibility and will be removed
in a future release. It has been deprecated in the Libav project to allow for
incompatible command line syntax improvements in its replacement called avconv
(see Changelog for details). Please use avconv instead.
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
 

Chris D

XenForo developer
Staff member
#17
Ok. So it is version 0.8.17.

This is an old build, but likely released fairly recently due to security fixes or some such.

My recommendation remains as yesterday, then:
Besides all that, a potential solution may be to get your host to use one of the static builds here:
http://johnvansickle.com/ffmpeg/

It's worth noting that these static builds are recommended by FFmpeg themselves. It should be just a case of downloading, extracting the files, and copying the ffmpeg binary to a location on the server and either updating the ffmpeg symlink or updating the path to FFmpeg in the Gallery Options.
 

Mike

XenForo developer
Staff member
#18
I'm not totally convinced that this isn't just an upload limit somewhere along the process. You mentioned downloading a video from here and testing, but the video you downloaded was about 2MB and you mention that this one is 327MB. There are a number of settings that may need to be changed to allow uploads of that size (within PHP, the web server, maybe any reverse proxies).

Try uploading it as an attachment. What happens? Do you get an error telling you it's too big or something else? (Note that you may temporarily need to allow the extension to be uploaded.)