RM 1.0 Unable to upload resource

Saarbruecken

Active member
Howdy :)

every time I try to upload a file on the Resource Manager, I keep getting the following error message:

Code:
The following error occurred
 
undefined
<file name>
/etc/php5/apache2/php.ini
upload_max_filesize = 8M
post_max_size = 8M

Nothing in Apache log though, file got only a few kilobytes, any ideas?
 

Saarbruecken

Active member
Hi

yeah, I also added additional file formats (which are not shown when attempting to upload them), but even the pre-defined file formats are not working (they are shown, but error message above when uploading).

Code:
Allowed Resource File Extensions (in admin.php?options/list/xenResourceManager)
 
zip
rar
txt
pdf
png
jpg
jpeg
jpe
gif
psd
tif
scn
scx
mgl
mgx
Users also have permission to download resources, anything else I missed to configure in Admin Control Panel?
 

Saarbruecken

Active member
Try turning off the Flash uploader and seeing if you get a better error message.
Hi

I have turned off Flash Uploader in admin.php?options/list/attachments and now the files have been uploaded successfully. I would prefer using the flash uploader though, want me to submit a ticket or do you have further things I could try first? Thanks.
 

Mike

XenForo developer
Staff member
Is your forum protected by HTTP auth? If so, the Flash uploader won't work.

Alternatively, there could be something coming from something like mod_security. You may need to check your web server error logs.
 

Saarbruecken

Active member
I guess I found it, the flash uploader seems to have problems with Squid Webcache.

Code:
1364388106.894    27 192.168.XXX.XXX TCP_DENIED/407 1768 POST http://www.XXXXXX.XXXXXX/attachments/do-upload.json?hash=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx&content_type=resource_version&key=resource - NONE/- text/html
 
Top