1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to revert templates

Discussion in 'XenForo Questions and Support' started by Steve F, Jun 6, 2011.

  1. Steve F

    Steve F Well-Known Member

    On my localhost using Xampp I cannot revert any templates. The error messages are not always the same either. This is a my install that I do all of my styles on so I currently have 19 styles plus the default style. Here are 2 of the error message I receive.

    Code:
    Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\xf\community\library\Zend\Db\Statement\Mysqli.php on line 70
    Code:
    Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\xf\community\library\Xenforo\Template\Compiler.php on line 597
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Steve F

    Steve F Well-Known Member

    Thanks Jake

    Guess I will have to do the later because I received this error after adding the line to my config.php.

    Code:
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 18161 bytes) in C:\xampp\htdocs\xf\community\library\XenForo\Template\Compiler\Statement\Raw.php on line 17
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  5. Mike

    Mike XenForo Developer Staff Member

    That error (the memory error) is likely happening if you're in debug mode. Debug mode can require significantly more memory on some actions due to query logging.

    The time error is from the number of styles.
     
  6. Steve F

    Steve F Well-Known Member

    The combination of turning off debug mode and increasing the time worked.

    Was having trouble getting Apache to restart in xampp which ended up being Skype using the same port I guess. :rolleyes:
     

Share This Page