Fixed Unable to revert customized style property

Affected version
2.0.0

Jake B.

Well-known member
#1
Style properties are showing "Value customized" if I've ever edited the value regardless if I've set it back to the default value, and I'm not seeing a way to actually revert it to the default to get rid of that
 

Chris D

XenForo developer
Staff member
#2
You can't revert a value merely by setting it to the default (this is the same as XF1).

The revert checkbox is underneath the modified property:
1502894047112.png

Is there a particular property this is happening with?
 

Jake B.

Well-known member
#3
You can't revert a value merely by setting it to the default (this is the same as XF1).

The revert checkbox is underneath the modified property:
View attachment 155904

Is there a particular property this is happening with?
Yeah, the "revert" checkbox is what I was expecting to see but didn't so assumed there was something wrong :p

It's a custom style property created in an add-on (though, just using the "Boolean" type so no custom templates)

Screen Shot 2017-08-16 at 9.56.52 AM.png

Able to replicate on some default style properties as well, for example:

Screen Shot 2017-08-16 at 9.58.05 AM.png

So I think the revert option is just missing on some types of style properties :)
 

Chris D

XenForo developer
Staff member
#4
Yeah, seems to be type dependent. I can confirm this with the formSubmitSticky property.

As a workaround for now, you can properly revert a property via Appearance > Styles > [...] menu > Customized components.
 
Top